https://issues.shibboleth.net/jira/browse/SSPCPP-584
[shibboleth/cpp-sp.git] / nsapi_shib / Makefile.am
index 0435454..32827a4 100644 (file)
@@ -1,19 +1,17 @@
 AUTOMAKE_OPTIONS = foreign
 
 if BUILD_NSAPI
-nsapi_shibdir = $(libexecdir)
+nsapi_shibdir = $(libdir)/@PACKAGE_NAME@
 nsapi_shib_LTLIBRARIES = nsapi_shib.la
 nsapi_shib_la_SOURCES = nsapi_shib.cpp
 nsapi_shib_la_CXXFLAGS = $(NSAPI_INCLUDE)
 nsapi_shib_la_LDFLAGS = -module -avoid-version
-nsapi_shib_la_LIBADD = \
-  $(top_builddir)/shib/libshib.la \
-  $(top_builddir)/shib-target/libshib-target.la
+nsapi_shib_la_LIBADD = $(LITE_LIBS) \
+  $(top_builddir)/shibsp/libshibsp-lite.la
 
-install-exec-hook:
+install-data-hook:
        for la in $(nsapi_shib_LTLIBRARIES) ; do rm -f $(DESTDIR)$(nsapi_shibdir)/$$la ; done
 
 endif
 
-EXTRA_DIST = nsapi_shib.vcproj resource.h nsapi_shib.rc nsapi_shib.cpp
-
+EXTRA_DIST = nsapi_shib.vcxproj resource.h nsapi_shib.rc nsapi_shib.cpp