Initial draft of protocol bootstrapper, reworked ACS lookup (again).
[shibboleth/cpp-sp.git] / shibsp / Makefile.am
index 39ca0e2..b677beb 100644 (file)
@@ -63,6 +63,7 @@ attrresinclude_HEADERS = \
 
 bindinclude_HEADERS = \
        binding/ArtifactResolver.h \
+       binding/ProtocolProvider.h \
        binding/SOAPClient.h
 
 handinclude_HEADERS = \
@@ -113,6 +114,7 @@ common_sources = \
        attribute/SimpleAttribute.cpp \
        attribute/ScopedAttribute.cpp \
        attribute/XMLAttribute.cpp \
+       binding/impl/XMLProtocolProvider.cpp \
        handler/impl/AbstractHandler.cpp \
        handler/impl/AssertionConsumerService.cpp \
        handler/impl/AssertionLookup.cpp \