Try to be smart about removing .la files.
[shibboleth/cpp-sp.git] / xmlproviders / Makefile.am
index 8c10d9f..f0b3051 100644 (file)
@@ -24,5 +24,8 @@ xmlproviders_la_SOURCES = \
 
 xmlproviders_la_LDFLAGS = -module -avoid-version
 
+install-exec-hook:
+       for la in $(plugin_LTLIBRARIES) ; do rm -f $(DESTDIR)$(plugindir)/$$la ; done
+
 EXTRA_DIST = xmlproviders.dsp