Bump to 1.3.1
[shibboleth/cpp-xmltooling.git] / doc / Makefile.am
index 42bec95..7ad576f 100644 (file)
@@ -1,10 +1,19 @@
-AUTOMAKE_OPTIONS = foreign\r
-\r
-pkgdocdir = $(prefix)/doc/@PACKAGE@\r
-\r
-pkgdoc_DATA = \\r
-       LICENSE.txt \\r
-       NOTICE.txt \\r
-       OPENSSL.LICENSE \\r
-       LOG4CPP.LICENSE \\r
-       CURL.LICENSE\r
+AUTOMAKE_OPTIONS = foreign
+
+pkgdocdir = $(datadir)/doc/@PACKAGE@-@PACKAGE_VERSION@
+
+install-data-hook:
+       cp -r api $(DESTDIR)$(pkgdocdir)
+       rm -rf `find $(DESTDIR)$(pkgdocdir)/api -name .svn`
+
+docfiles = \
+       README.txt \
+       LICENSE.txt \
+       NOTICE.txt \
+       OPENSSL.LICENSE \
+       LOG4CPP.LICENSE \
+       CURL.LICENSE
+
+pkgdoc_DATA = $(docfiles)
+
+EXTRA_DIST = $(docfiles) api