Remove api directory from distribution.
[shibboleth/cpp-xmltooling.git] / doc / Makefile.am
index f40c98f..fa84046 100644 (file)
@@ -3,12 +3,12 @@ AUTOMAKE_OPTIONS = foreign
 pkgdocdir = $(datadir)/doc/@PACKAGE@-@PACKAGE_VERSION@
 
 install-data-hook:
-    rm -rf $(DESTDIR)$(pkgdocdir)/api
-    cp -r doc/api $(DESTDIR)$(pkgdocdir)
-    rm -rf `find $(DESTDIR)$(pkgdocdir)/api -name .svn`
+       if test -d api ; then \
+               cp -r api $(DESTDIR)$(pkgdocdir); \
+       fi;
 
 docfiles = \
-    README.txt \
+       README.txt \
        LICENSE.txt \
        NOTICE.txt \
        OPENSSL.LICENSE \
@@ -17,4 +17,4 @@ docfiles = \
 
 pkgdoc_DATA = $(docfiles)
 
-EXTRA_DIST = $(docfiles) api
+EXTRA_DIST = $(docfiles)