Threading support.
[shibboleth/cpp-xmltooling.git] / xmltooling / Makefile.am
index 0e8cdfe..9681b81 100644 (file)
@@ -65,6 +65,7 @@ utilinclude_HEADERS = \
        util/DateTime.h \
        util/NDC.h \
        util/ParserPool.h \
+       util/Threads.h \
        util/XMLConstants.h \
        util/XMLHelper.h \
        util/XMLObjectChildrenList.h
@@ -87,6 +88,12 @@ else
 xmlsec_sources =
 endif
 
+if BUILD_PTHREAD
+thread_sources = PThread.cpp
+else
+thread_sources =
+endif
+
 libxmltooling_la_SOURCES = \
        AbstractAttributeExtensibleXMLObject.cpp \
        AbstractChildlessElement.cpp \
@@ -114,7 +121,8 @@ libxmltooling_la_SOURCES = \
        util/XMLHelper.cpp \
        validation/AbstractValidatingXMLObject.cpp \
        validation/Validator.cpp \
-       ${xmlsec_sources}
+       ${xmlsec_sources} \
+       $(thread_sources)
 
 # this is different from the project version
 # http://sources.redhat.com/autobook/autobook/autobook_91.html