Merged marshalling/unmarshalling methods into core interface.
[shibboleth/cpp-xmltooling.git] / xmltooling / Makefile.am
index a26eb12..e90aca3 100644 (file)
@@ -34,12 +34,11 @@ libxmltoolinginclude_HEADERS = \
 
 ioinclude_HEADERS = \
     io/AbstractXMLObjectUnmarshaller.h \
-    io/Marshaller.h \
-    io/Unmarshaller.h
 
 siginclude_HEADERS = \
     signature/Signature.h \
-    signature/SigningContext.h
+    signature/SigningContext.h \
+    signature/VerifyingContext.h
 
 utilinclude_HEADERS = \
     util/NDC.h \
@@ -67,6 +66,7 @@ libxmltooling_la_SOURCES = \
     AbstractAttributeExtensibleXMLObject.cpp \
     AbstractDOMCachingXMLObject.cpp \
     AbstractElementProxy.cpp \
+    AbstractXMLObject.cpp \
     Namespace.cpp \
     QName.cpp \
     unicode.cpp \
@@ -75,8 +75,6 @@ libxmltooling_la_SOURCES = \
     impl/UnknownElement.cpp \
     io/AbstractXMLObjectMarshaller.cpp \
     io/AbstractXMLObjectUnmarshaller.cpp \
-    io/Marshaller.cpp \
-    io/Unmarshaller.cpp \
     util/NDC.cpp \
     util/ParserPool.cpp \
     util/XMLConstants.cpp \