Template replacement engine ported from Shib, added conditional nesting.
[shibboleth/cpp-xmltooling.git] / xmltoolingtest / Makefile.am
index 0e26bc0..4314674 100644 (file)
@@ -9,16 +9,22 @@ endif
 
 if BUILD_XMLSEC
 xmlsec_sources = \
-    Signature.h
+    EncryptionTest.h \
+    FilesystemCredentialResolverTest.h \
+    InlineKeyResolverTest.h \
+    SignatureTest.h
 else
 xmlsec_sources =
 endif
 
 xmltoolingtest_h = \
     ComplexXMLObjectTest.h \
+    ExceptionTest.h \
+    KeyInfoTest.h \
     MarshallingTest.h \
-    UnknownTest.h \
+    MemoryStorageServiceTest.h \
     UnmarshallingTest.h \
+    TemplateEngineTest.h \
     xmltoolingtest.h \
     ${xmlsec_sources}