Remove some tracing, fix string compares.
[shibboleth/cpp-xmltooling.git] / xmltoolingtest / Makefile.am
index 92f35d3..4525b08 100644 (file)
@@ -7,13 +7,23 @@ else
 bin_PROGRAMS = 
 endif
 
+if BUILD_XMLSEC
+xmlsec_sources = \
+    EncryptionTest.h \
+    FilesystemCredentialResolverTest.h \
+    SignatureTest.h
+else
+xmlsec_sources =
+endif
+
 xmltoolingtest_h = \
     ComplexXMLObjectTest.h \
+    ExceptionTest.h \
+    KeyInfoTest.h \
     MarshallingTest.h \
-    Signature.h \
-    UnknownTest.h \
     UnmarshallingTest.h \
-    xmltoolingtest.h
+    xmltoolingtest.h \
+    ${xmlsec_sources}
 
 noinst_HEADERS = \
     XMLObjectBaseTestCase.h