Xerces 3 revisions.
[shibboleth/cpp-xmltooling.git] / xmltoolingtest / Makefile.am
index 69538ec..5698e75 100644 (file)
@@ -1,15 +1,29 @@
 AUTOMAKE_OPTIONS = foreign
 
 if BUILD_UNITTEST
+
 bin_PROGRAMS = xmltoolingtest
-xmltoolingtest_CXXFLAGS = $(CXXFLAGS) $(CXXTESTFLAGS)
+xmltoolingtest_CXXFLAGS = $(CXXTESTFLAGS)
+if BUILD_XMLSEC
+xmltoolingtest_LDFLAGS = $(XMLSEC_LIBS)
+xmltoolingtest_LDADD = $(top_builddir)/xmltooling/libxmltooling.la
+else
+xmltoolingtest_LDADD = $(top_builddir)/xmltooling/libxmltooling-lite.la
+endif
+
 else
+
 bin_PROGRAMS = 
+
 endif
 
 if BUILD_XMLSEC
 xmlsec_sources = \
     EncryptionTest.h \
+    FilesystemCredentialResolverTest.h \
+    InlineKeyResolverTest.h \
+    MemoryStorageServiceTest.h \
+    SecurityHelperTest.h \
     SignatureTest.h
 else
 xmlsec_sources =
@@ -17,10 +31,12 @@ endif
 
 xmltoolingtest_h = \
     ComplexXMLObjectTest.h \
+    DateTimeTest.h \
     ExceptionTest.h \
     KeyInfoTest.h \
     MarshallingTest.h \
     UnmarshallingTest.h \
+    TemplateEngineTest.h \
     xmltoolingtest.h \
     ${xmlsec_sources}
 
@@ -41,6 +57,4 @@ do-cxxtestgen:
 $(nodist_xmltoolingtest_SOURCES): %.cpp: %.h
        $(MAKE) do-cxxtestgen HFILE=$< CPPFILE=$@
 
-xmltoolingtest_LDADD = $(top_builddir)/xmltooling/libxmltooling.la
-
 EXTRA_DIST = xmltoolingtest.vcproj $(xmltoolingtest_h) data