Removed ValidatingXMLObject interface and implementations.
[shibboleth/cpp-xmltooling.git] / xmltoolingtest / Makefile.am
index 1718841..69538ec 100644 (file)
@@ -7,14 +7,25 @@ else
 bin_PROGRAMS = 
 endif
 
+if BUILD_XMLSEC
+xmlsec_sources = \
+    EncryptionTest.h \
+    SignatureTest.h
+else
+xmlsec_sources =
+endif
+
 xmltoolingtest_h = \
-       xmltoolingtest.h \
-       MarshallingTest.h \
-       UnknownTest.h \
-       UnmarshallingTest.h
+    ComplexXMLObjectTest.h \
+    ExceptionTest.h \
+    KeyInfoTest.h \
+    MarshallingTest.h \
+    UnmarshallingTest.h \
+    xmltoolingtest.h \
+    ${xmlsec_sources}
 
 noinst_HEADERS = \
-       XMLObjectBaseTestCase.h
+    XMLObjectBaseTestCase.h
 
 nodist_xmltoolingtest_SOURCES = $(xmltoolingtest_h:.h=.cpp)