Add non-working PKIX unit test and test data.
[shibboleth/cpp-xmltooling.git] / xmltoolingtest / Makefile.am
index a60d78a..8e56618 100644 (file)
@@ -23,6 +23,7 @@ xmlsec_sources = \
     FilesystemCredentialResolverTest.h \
     InlineKeyResolverTest.h \
     MemoryStorageServiceTest.h \
+    PKIXEngineTest.h \
     SecurityHelperTest.h \
     SignatureTest.h
 else
@@ -43,14 +44,17 @@ xmltoolingtest_h = \
     ${xmlsec_sources}
 
 noinst_HEADERS = \
-    XMLObjectBaseTestCase.h
+    XMLObjectBaseTestCase.h \
+    $(xmltoolingtest_h)
 
 nodist_xmltoolingtest_SOURCES = $(xmltoolingtest_h:.h=.cpp)
 
+BUILT_SOURCES = $(nodist_xmltoolingtest_SOURCES)
+
 CLEANFILES = $(nodist_xmltoolingtest_SOURCES)
 
 do-cxxtestgen:
-       if test $(HFILE) = "xmltoolingtest.h"; then \
+       if test "$(CPPFILE)" = "xmltoolingtest.cpp"; then \
                $(CXXTEST) --error-printer --have-eh --have-std --abort-on-fail -o $(CPPFILE) $(HFILE); \
        else \
                $(CXXTEST) --part --have-eh --have-std --abort-on-fail -o $(CPPFILE) $(HFILE); \
@@ -59,4 +63,4 @@ do-cxxtestgen:
 $(nodist_xmltoolingtest_SOURCES): %.cpp: %.h
        $(MAKE) do-cxxtestgen HFILE=$< CPPFILE=$@
 
-EXTRA_DIST = xmltoolingtest.vcxproj xmltoolingtest.vcxproj.filters $(xmltoolingtest_h) data
+EXTRA_DIST = xmltoolingtest.vcxproj xmltoolingtest.vcxproj.filters data