Adjust cxxtest path in build rules.
[shibboleth/cpp-xmltooling.git] / xmltoolingtest / Makefile.am
index c3243c9..be57473 100644 (file)
@@ -1,18 +1,45 @@
 AUTOMAKE_OPTIONS = foreign
 
 if BUILD_UNITTEST
+
 bin_PROGRAMS = xmltoolingtest
-xmltoolingtest_CXXFLAGS = $(CXXFLAGS) $(CXXTESTFLAGS)
+xmltoolingtest_CXXFLAGS = $(CXXTESTFLAGS)
+if BUILD_XMLSEC
+xmltoolingtest_LDFLAGS = $(XMLSEC_LIBS)
+xmltoolingtest_LDADD = $(top_builddir)/xmltooling/libxmltooling.la
+else
+xmltoolingtest_LDADD = $(top_builddir)/xmltooling/libxmltooling-lite.la
+endif
+
 else
+
 bin_PROGRAMS = 
+
+endif
+
+if BUILD_XMLSEC
+xmlsec_sources = \
+    EncryptionTest.h \
+    FilesystemCredentialResolverTest.h \
+    InlineKeyResolverTest.h \
+    MemoryStorageServiceTest.h \
+    SecurityHelperTest.h \
+    SignatureTest.h
+else
+xmlsec_sources =
 endif
 
 xmltoolingtest_h = \
     ComplexXMLObjectTest.h \
+    DateTimeTest.h \
+    ExceptionTest.h \
+    KeyInfoTest.h \
     MarshallingTest.h \
-    UnknownTest.h \
+    NonVisibleNamespaceTest.h \
     UnmarshallingTest.h \
-    xmltoolingtest.h
+    TemplateEngineTest.h \
+    xmltoolingtest.h \
+    ${xmlsec_sources}
 
 noinst_HEADERS = \
     XMLObjectBaseTestCase.h
@@ -31,6 +58,4 @@ do-cxxtestgen:
 $(nodist_xmltoolingtest_SOURCES): %.cpp: %.h
        $(MAKE) do-cxxtestgen HFILE=$< CPPFILE=$@
 
-xmltoolingtest_LDADD = $(top_builddir)/xmltooling/libxmltooling.la
-
-EXTRA_DIST = xmltoolingtest.vcproj $(xmltoolingtest_h) data
+EXTRA_DIST = xmltoolingtest.vcxproj xmltoolingtest.vcxproj.filters $(xmltoolingtest_h) data