Form generator for discovery along with sample form.
[shibboleth/sp.git] / configs / Makefile.am
index 4d798b4..24baa09 100644 (file)
@@ -2,10 +2,10 @@
 
 AUTOMAKE_OPTIONS = foreign
 
+pkglibdir = ${libdir}/@PACKAGE@
 pkglogdir = ${localstatedir}/log/@PACKAGE@
 pkgdocdir = ${datadir}/doc/@PACKAGE@
 shirelogdir = ${localstatedir}/log/httpd
-xmldir = $(datadir)/xml
 pkgxmldir = $(datadir)/xml/@PACKAGE@
 pkgrundir = $(localstatedir)/run/@PACKAGE@
 pkgsysconfdir = $(sysconfdir)/@PACKAGE@
@@ -15,34 +15,34 @@ pkgsysconf_DATA = \
        shibd-osx.plist \
        apache.config \
        apache2.config \
-       apache22.config
+       apache22.config \
+       keygen.sh
 
 # The config files are installed "special".  Unlike the entries in
 # pkgsysconf_DATA, these files are installed as "foo.dist" and only
 # installed as "foo" if "foo" does not already exist.  In other words,
 # the config files will not overwrite existing versions.
 BUILTCONFIGFILES = \
-       shibboleth2.xml \
        native.logger \
-       shibd.logger \
-       attribute-map.xml \
-       attribute-policy.xml \
-       example-metadata.xml
+       shibd.logger
 
 # While BUILTCONFIGFILES are processed, these are not; so we should pull
 # them from SRCDIR.
 CONFIGFILES = \
+       shibboleth2.xml \
+       attribute-map.xml \
+       attribute-policy.xml \
+       example-metadata.xml \
        console.logger \
        syslog.logger \
        accessError.html \
        sessionError.html \
        metadataError.html \
        bindingTemplate.html \
+       discoveryTemplate.html \
        localLogout.html \
        globalLogout.html \
-       sslError.html \
-       sp-example.key \
-       sp-example.crt
+       sslError.html
 
 #
 # Some of these need building
@@ -51,11 +51,10 @@ do-build-file:
        rm -f ${FILE}.tmp
        sed < ${srcdir}/${FILE}.in > ${FILE}.tmp \
         -e 's:@-PREFIX-@:${prefix}:g' \
-        -e 's:@-LIBEXECDIR-@:${libexecdir}:g' \
+        -e 's:@-PKGLIBDIR-@:${pkglibdir}:g' \
         -e 's:@-PKGSYSCONFDIR-@:${pkgsysconfdir}:g' \
-        -e 's:@-PKGXMLDIR-@:${pkgxmldir}:g' \
         -e 's:@-PKGDOCDIR-@:${pkgdocdir}:g' \
-        -e 's:@-XMLDIR-@:${xmldir}:g' \
+        -e 's:@-PKGXMLDIR-@:${pkgxmldir}:g' \
         -e 's:@-PKGLOGDIR-@:${pkglogdir}:g' \
         -e 's:@-SHIRELOGDIR-@:${shirelogdir}:g' \
         -e 's:@-PKGRUNDIR-@:${pkgrundir}:g'
@@ -86,18 +85,6 @@ shibd.logger: ${srcdir}/shibd.logger.in Makefile ${top_builddir}/config.status
 native.logger: ${srcdir}/native.logger.in Makefile ${top_builddir}/config.status
        $(MAKE) do-build-file FILE=$@
 
-shibboleth2.xml: ${srcdir}/shibboleth2.xml.in Makefile ${top_builddir}/config.status
-       $(MAKE) do-build-file FILE=$@
-
-attribute-map.xml: ${srcdir}/attribute-map.xml.in Makefile ${top_builddir}/config.status
-       $(MAKE) do-build-file FILE=$@
-
-attribute-policy.xml: ${srcdir}/attribute-policy.xml.in Makefile ${top_builddir}/config.status
-       $(MAKE) do-build-file FILE=$@
-
-example-metadata.xml: ${srcdir}/example-metadata.xml.in Makefile ${top_builddir}/config.status
-       $(MAKE) do-build-file FILE=$@
-
 all-data-local: $(BUILTCONFIGFILES)
 
 install-data-local:    all-data-local
@@ -120,6 +107,12 @@ install-data-local:        all-data-local
                $(INSTALL_DATA) $(srcdir)/$$f $(DESTDIR)${pkgsysconfdir}/$$f.dist; \
         done
 
+install-data-hook:
+       if test -z "$(NOKEYGEN)"; then \
+               cd $(DESTDIR)$(pkgsysconfdir); \
+               sh ./keygen.sh -b ; \
+       fi
+
 CLEANFILES = \
        apache.config \
        apache2.config \
@@ -128,17 +121,9 @@ CLEANFILES = \
        shibd-debian \
        shibd-osx.plist \
        shibd.logger \
-       native.logger \
-       shibboleth2.xml \
-       attribute-map.xml \
-       attribute-policy.xml \
-       example-metadata.xml
+       native.logger
 
 EXTRA_DIST = \
-       shibboleth2.xml.in \
-       attribute-map.xml.in \
-       attribute-policy.xml.in \
-       example-metadata.xml.in \
        native.logger.in \
        shibd.logger.in \
        apache.config.in \
@@ -147,4 +132,6 @@ EXTRA_DIST = \
        shibd-redhat.in \
        shibd-debian.in \
        shibd-osx.plist.in \
+       keygen.bat \
+       keygen.sh \
        $(CONFIGFILES)