Form generator for discovery along with sample form.
[shibboleth/sp.git] / configs / Makefile.am
index afb642d..24baa09 100644 (file)
@@ -15,7 +15,8 @@ pkgsysconf_DATA = \
        shibd-osx.plist \
        apache.config \
        apache2.config \
-       apache22.config
+       apache22.config \
+       keygen.sh
 
 # The config files are installed "special".  Unlike the entries in
 # pkgsysconf_DATA, these files are installed as "foo.dist" and only
@@ -28,21 +29,20 @@ BUILTCONFIGFILES = \
 # While BUILTCONFIGFILES are processed, these are not; so we should pull
 # them from SRCDIR.
 CONFIGFILES = \
-    shibboleth2.xml \
-    attribute-map.xml \
-    attribute-policy.xml \
-    example-metadata.xml \
+       shibboleth2.xml \
+       attribute-map.xml \
+       attribute-policy.xml \
+       example-metadata.xml \
        console.logger \
        syslog.logger \
        accessError.html \
        sessionError.html \
        metadataError.html \
        bindingTemplate.html \
+       discoveryTemplate.html \
        localLogout.html \
        globalLogout.html \
-       sslError.html \
-       sp-example.key \
-       sp-example.crt
+       sslError.html
 
 #
 # Some of these need building
@@ -107,6 +107,12 @@ install-data-local:        all-data-local
                $(INSTALL_DATA) $(srcdir)/$$f $(DESTDIR)${pkgsysconfdir}/$$f.dist; \
         done
 
+install-data-hook:
+       if test -z "$(NOKEYGEN)"; then \
+               cd $(DESTDIR)$(pkgsysconfdir); \
+               sh ./keygen.sh -b ; \
+       fi
+
 CLEANFILES = \
        apache.config \
        apache2.config \
@@ -126,4 +132,6 @@ EXTRA_DIST = \
        shibd-redhat.in \
        shibd-debian.in \
        shibd-osx.plist.in \
+       keygen.bat \
+       keygen.sh \
        $(CONFIGFILES)