Form generator for discovery along with sample form.
[shibboleth/sp.git] / configs / Makefile.am
index b59f561..24baa09 100644 (file)
@@ -2,42 +2,47 @@
 
 AUTOMAKE_OPTIONS = foreign
 
+pkglibdir = ${libdir}/@PACKAGE@
 pkglogdir = ${localstatedir}/log/@PACKAGE@
+pkgdocdir = ${datadir}/doc/@PACKAGE@
 shirelogdir = ${localstatedir}/log/httpd
 pkgxmldir = $(datadir)/xml/@PACKAGE@
-varrundir = $(localstatedir)/run
+pkgrundir = $(localstatedir)/run/@PACKAGE@
 pkgsysconfdir = $(sysconfdir)/@PACKAGE@
 pkgsysconf_DATA = \
-       shibd \
+       shibd-redhat \
+       shibd-debian \
+       shibd-osx.plist \
        apache.config \
        apache2.config \
-       apache22.config
+       apache22.config \
+       keygen.sh
 
 # The config files are installed "special".  Unlike the entries in
 # pkgsysconf_DATA, these files are installed as "foo.dist" and only
 # installed as "foo" if "foo" does not already exist.  In other words,
 # the config files will not overwrite existing versions.
 BUILTCONFIGFILES = \
-       shibboleth.xml \
        native.logger \
-       shibd.logger \
-       attribute-map.xml \
-       attribute-policy.xml \
-       example-metadata.xml
+       shibd.logger
 
 # While BUILTCONFIGFILES are processed, these are not; so we should pull
 # them from SRCDIR.
 CONFIGFILES = \
+       shibboleth2.xml \
+       attribute-map.xml \
+       attribute-policy.xml \
+       example-metadata.xml \
        console.logger \
        syslog.logger \
        accessError.html \
-       rmError.html \
        sessionError.html \
        metadataError.html \
        bindingTemplate.html \
-       sslError.html \
-       sp-example.key \
-       sp-example.crt
+       discoveryTemplate.html \
+       localLogout.html \
+       globalLogout.html \
+       sslError.html
 
 #
 # Some of these need building
@@ -45,13 +50,14 @@ CONFIGFILES = \
 do-build-file:
        rm -f ${FILE}.tmp
        sed < ${srcdir}/${FILE}.in > ${FILE}.tmp \
-           -e 's:@-PREFIX-@:${prefix}:g' \
-           -e 's:@-LIBEXECDIR-@:${libexecdir}:g' \
-           -e 's:@-PKGSYSCONFDIR-@:${pkgsysconfdir}:g' \
-           -e 's:@-PKGXMLDIR-@:${pkgxmldir}:g' \
-           -e 's:@-PKGLOGDIR-@:${pkglogdir}:g' \
-           -e 's:@-SHIRELOGDIR-@:${shirelogdir}:g' \
-           -e 's:@-VARRUNDIR-@:${varrundir}:g'
+        -e 's:@-PREFIX-@:${prefix}:g' \
+        -e 's:@-PKGLIBDIR-@:${pkglibdir}:g' \
+        -e 's:@-PKGSYSCONFDIR-@:${pkgsysconfdir}:g' \
+        -e 's:@-PKGDOCDIR-@:${pkgdocdir}:g' \
+        -e 's:@-PKGXMLDIR-@:${pkgxmldir}:g' \
+        -e 's:@-PKGLOGDIR-@:${pkglogdir}:g' \
+        -e 's:@-SHIRELOGDIR-@:${shirelogdir}:g' \
+        -e 's:@-PKGRUNDIR-@:${pkgrundir}:g'
        cmp -s ${FILE} ${FILE}.tmp || mv ${FILE}.tmp ${FILE}
        rm -f ${FILE}.tmp
 
@@ -64,35 +70,29 @@ apache2.config: ${srcdir}/apache2.config.in Makefile ${top_builddir}/config.stat
 apache22.config: ${srcdir}/apache22.config.in Makefile ${top_builddir}/config.status
        $(MAKE) do-build-file FILE=$@
 
-shibd: ${srcdir}/shibd.in Makefile ${top_builddir}/config.status
-       $(MAKE) do-build-file FILE=$@
-
-shibd.logger: ${srcdir}/shibd.logger.in Makefile ${top_builddir}/config.status
-       $(MAKE) do-build-file FILE=$@
-
-native.logger: ${srcdir}/native.logger.in Makefile ${top_builddir}/config.status
+shibd-redhat: ${srcdir}/shibd-redhat.in Makefile ${top_builddir}/config.status
        $(MAKE) do-build-file FILE=$@
 
-shibboleth.xml: ${srcdir}/shibboleth.xml.in Makefile ${top_builddir}/config.status
+shibd-debian: ${srcdir}/shibd-debian.in Makefile ${top_builddir}/config.status
        $(MAKE) do-build-file FILE=$@
 
-attribute-map.xml: ${srcdir}/attribute-map.xml.in Makefile ${top_builddir}/config.status
+shibd-osx.plist: ${srcdir}/shibd-osx.plist.in Makefile ${top_builddir}/config.status
        $(MAKE) do-build-file FILE=$@
 
-attribute-policy.xml: ${srcdir}/attribute-policy.xml.in Makefile ${top_builddir}/config.status
+shibd.logger: ${srcdir}/shibd.logger.in Makefile ${top_builddir}/config.status
        $(MAKE) do-build-file FILE=$@
 
-example-metadata.xml: ${srcdir}/example-metadata.xml.in Makefile ${top_builddir}/config.status
+native.logger: ${srcdir}/native.logger.in Makefile ${top_builddir}/config.status
        $(MAKE) do-build-file FILE=$@
 
 all-data-local: $(BUILTCONFIGFILES)
 
 install-data-local:    all-data-local
        $(mkinstalldirs) $(DESTDIR)$(pkglogdir)
+       $(mkinstalldirs) $(DESTDIR)$(pkgdocdir)
        $(mkinstalldirs) $(DESTDIR)$(shirelogdir)
-       $(mkinstalldirs) $(DESTDIR)$(varrundir)
+       $(mkinstalldirs) $(DESTDIR)$(pkgrundir)
        $(mkinstalldirs) $(DESTDIR)$(pkgxmldir)
-       $(mkinstalldirs) $(DESTDIR)$(prefix)/data
        $(mkinstalldirs) $(DESTDIR)$(pkgsysconfdir)
        for f in $(BUILTCONFIGFILES); do \
                if test ! -f $(DESTDIR)${pkgsysconfdir}/$$f; then \
@@ -107,35 +107,31 @@ install-data-local:       all-data-local
                $(INSTALL_DATA) $(srcdir)/$$f $(DESTDIR)${pkgsysconfdir}/$$f.dist; \
         done
 
+install-data-hook:
+       if test -z "$(NOKEYGEN)"; then \
+               cd $(DESTDIR)$(pkgsysconfdir); \
+               sh ./keygen.sh -b ; \
+       fi
+
 CLEANFILES = \
        apache.config \
        apache2.config \
        apache22.config \
-       shibd \
+       shibd-redhat \
+       shibd-debian \
+       shibd-osx.plist \
        shibd.logger \
-       native.logger \
-       shibboleth.xml \
-       attribute-map.xml \
-       attribute-policy.xml \
-       example-metadata.xml
+       native.logger
 
 EXTRA_DIST = \
-       shibboleth.xml.in \
-       attribute-map.xml.in \
-       attribute-policy.xml.in \
-       example-metadata.xml.in \
        native.logger.in \
        shibd.logger.in \
        apache.config.in \
        apache2.config.in \
        apache22.config.in \
-       shibd.in \
-       console.logger \
-       syslog.logger \
-       accessError.html \
-       rmError.html \
-       sessionError.html \
-       metadataError.html \
-       sslError.html \
-       sp-example.key \
-       sp-example.crt
+       shibd-redhat.in \
+       shibd-debian.in \
+       shibd-osx.plist.in \
+       keygen.bat \
+       keygen.sh \
+       $(CONFIGFILES)