Form generator for discovery along with sample form.
[shibboleth/sp.git] / configs / Makefile.am
index ce067cc..24baa09 100644 (file)
@@ -29,16 +29,17 @@ BUILTCONFIGFILES = \
 # While BUILTCONFIGFILES are processed, these are not; so we should pull
 # them from SRCDIR.
 CONFIGFILES = \
-    shibboleth2.xml \
-    attribute-map.xml \
-    attribute-policy.xml \
-    example-metadata.xml \
+       shibboleth2.xml \
+       attribute-map.xml \
+       attribute-policy.xml \
+       example-metadata.xml \
        console.logger \
        syslog.logger \
        accessError.html \
        sessionError.html \
        metadataError.html \
        bindingTemplate.html \
+       discoveryTemplate.html \
        localLogout.html \
        globalLogout.html \
        sslError.html
@@ -105,10 +106,12 @@ install-data-local:       all-data-local
                fi; \
                $(INSTALL_DATA) $(srcdir)/$$f $(DESTDIR)${pkgsysconfdir}/$$f.dist; \
         done
-    if test -z $NOKEYGEN ; then
-        cd $(DESTDIR)$(pkgsysconfdir)
-        sh ./keygen.sh -b
-    fi
+
+install-data-hook:
+       if test -z "$(NOKEYGEN)"; then \
+               cd $(DESTDIR)$(pkgsysconfdir); \
+               sh ./keygen.sh -b ; \
+       fi
 
 CLEANFILES = \
        apache.config \
@@ -129,5 +132,6 @@ EXTRA_DIST = \
        shibd-redhat.in \
        shibd-debian.in \
        shibd-osx.plist.in \
-    keygen.bat \
+       keygen.bat \
+       keygen.sh \
        $(CONFIGFILES)