https://bugs.internet2.edu/jira/browse/SSPCPP-293
[shibboleth/sp.git] / configs / Makefile.am
index afb642d..5657d95 100644 (file)
@@ -4,18 +4,22 @@ AUTOMAKE_OPTIONS = foreign
 
 pkglibdir = ${libdir}/@PACKAGE@
 pkglogdir = ${localstatedir}/log/@PACKAGE@
-pkgdocdir = ${datadir}/doc/@PACKAGE@
+pkgdocdir = $(datadir)/doc/@PACKAGE@-@PACKAGE_VERSION@
 shirelogdir = ${localstatedir}/log/httpd
 pkgxmldir = $(datadir)/xml/@PACKAGE@
 pkgrundir = $(localstatedir)/run/@PACKAGE@
 pkgsysconfdir = $(sysconfdir)/@PACKAGE@
 pkgsysconf_DATA = \
        shibd-redhat \
+       shibd-suse \
        shibd-debian \
        shibd-osx.plist \
        apache.config \
        apache2.config \
-       apache22.config
+       apache22.config \
+       keygen.sh \
+       metagen.sh \
+       upgrade.xsl
 
 # The config files are installed "special".  Unlike the entries in
 # pkgsysconf_DATA, these files are installed as "foo.dist" and only
@@ -28,21 +32,23 @@ BUILTCONFIGFILES = \
 # While BUILTCONFIGFILES are processed, these are not; so we should pull
 # them from SRCDIR.
 CONFIGFILES = \
-    shibboleth2.xml \
-    attribute-map.xml \
-    attribute-policy.xml \
-    example-metadata.xml \
+       shibboleth2.xml \
+       attribute-map.xml \
+       attribute-policy.xml \
+       security-policy.xml \
+       example-metadata.xml \
        console.logger \
        syslog.logger \
        accessError.html \
        sessionError.html \
        metadataError.html \
        bindingTemplate.html \
+       discoveryTemplate.html \
+    postTemplate.html \
        localLogout.html \
        globalLogout.html \
-       sslError.html \
-       sp-example.key \
-       sp-example.crt
+       partialLogout.html \
+       sslError.html
 
 #
 # Some of these need building
@@ -73,6 +79,9 @@ apache22.config: ${srcdir}/apache22.config.in Makefile ${top_builddir}/config.st
 shibd-redhat: ${srcdir}/shibd-redhat.in Makefile ${top_builddir}/config.status
        $(MAKE) do-build-file FILE=$@
 
+shibd-suse: ${srcdir}/shibd-suse.in Makefile ${top_builddir}/config.status
+       $(MAKE) do-build-file FILE=$@
+
 shibd-debian: ${srcdir}/shibd-debian.in Makefile ${top_builddir}/config.status
        $(MAKE) do-build-file FILE=$@
 
@@ -107,11 +116,20 @@ install-data-local:       all-data-local
                $(INSTALL_DATA) $(srcdir)/$$f $(DESTDIR)${pkgsysconfdir}/$$f.dist; \
         done
 
+install-data-hook:
+       chmod +x $(DESTDIR)$(pkgsysconfdir)/keygen.sh
+       chmod +x $(DESTDIR)$(pkgsysconfdir)/metagen.sh
+       if test -z "$(NOKEYGEN)"; then \
+               cd $(DESTDIR)$(pkgsysconfdir); \
+               sh ./keygen.sh -b ; \
+       fi
+
 CLEANFILES = \
        apache.config \
        apache2.config \
        apache22.config \
        shibd-redhat \
+       shibd-suse \
        shibd-debian \
        shibd-osx.plist \
        shibd.logger \
@@ -124,6 +142,12 @@ EXTRA_DIST = \
        apache2.config.in \
        apache22.config.in \
        shibd-redhat.in \
+       shibd-suse.in \
        shibd-debian.in \
        shibd-osx.plist.in \
+       keygen.bat \
+       keygen.sh \
+       metagen.sh \
+       upgrade.xsl \
+       xsltproc.js \
        $(CONFIGFILES)