Fix separator problem again.
[shibboleth/sp.git] / configs / Makefile.am
index 167b0d5..7b394e1 100644 (file)
@@ -15,7 +15,8 @@ pkgsysconf_DATA = \
        shibd-osx.plist \
        apache.config \
        apache2.config \
-       apache22.config
+       apache22.config \
+       keygen.sh
 
 # The config files are installed "special".  Unlike the entries in
 # pkgsysconf_DATA, these files are installed as "foo.dist" and only
@@ -104,6 +105,10 @@ install-data-local:        all-data-local
                fi; \
                $(INSTALL_DATA) $(srcdir)/$$f $(DESTDIR)${pkgsysconfdir}/$$f.dist; \
         done
+    if test -z $NOKEYGEN ; then \
+        cd $(DESTDIR)$(pkgsysconfdir); \
+        sh ./keygen.sh -b ; \
+    fi
 
 CLEANFILES = \
        apache.config \
@@ -124,5 +129,5 @@ EXTRA_DIST = \
        shibd-redhat.in \
        shibd-debian.in \
        shibd-osx.plist.in \
-       $(CONFIGFILES) \
-       keygen.bat
+    keygen.bat \
+       $(CONFIGFILES)