Path resolution for error templates.
[shibboleth/sp.git] / configs / Makefile.am
index 26d969e..afb642d 100644 (file)
@@ -22,16 +22,16 @@ pkgsysconf_DATA = \
 # installed as "foo" if "foo" does not already exist.  In other words,
 # the config files will not overwrite existing versions.
 BUILTCONFIGFILES = \
-       shibboleth2.xml \
        native.logger \
-       shibd.logger \
-       attribute-map.xml \
-       attribute-policy.xml \
-       example-metadata.xml
+       shibd.logger
 
 # While BUILTCONFIGFILES are processed, these are not; so we should pull
 # them from SRCDIR.
 CONFIGFILES = \
+    shibboleth2.xml \
+    attribute-map.xml \
+    attribute-policy.xml \
+    example-metadata.xml \
        console.logger \
        syslog.logger \
        accessError.html \
@@ -55,8 +55,6 @@ do-build-file:
         -e 's:@-PKGSYSCONFDIR-@:${pkgsysconfdir}:g' \
         -e 's:@-PKGDOCDIR-@:${pkgdocdir}:g' \
         -e 's:@-PKGXMLDIR-@:${pkgxmldir}:g' \
-        -e 's:@-XMLTOOLINGXMLDIR-@:${XMLTOOLINGXMLDIR}:g' \
-        -e 's:@-OPENSAMLXMLDIR-@:${OPENSAMLXMLDIR}:g' \
         -e 's:@-PKGLOGDIR-@:${pkglogdir}:g' \
         -e 's:@-SHIRELOGDIR-@:${shirelogdir}:g' \
         -e 's:@-PKGRUNDIR-@:${pkgrundir}:g'
@@ -87,18 +85,6 @@ shibd.logger: ${srcdir}/shibd.logger.in Makefile ${top_builddir}/config.status
 native.logger: ${srcdir}/native.logger.in Makefile ${top_builddir}/config.status
        $(MAKE) do-build-file FILE=$@
 
-shibboleth2.xml: ${srcdir}/shibboleth2.xml.in Makefile ${top_builddir}/config.status
-       $(MAKE) do-build-file FILE=$@
-
-attribute-map.xml: ${srcdir}/attribute-map.xml.in Makefile ${top_builddir}/config.status
-       $(MAKE) do-build-file FILE=$@
-
-attribute-policy.xml: ${srcdir}/attribute-policy.xml.in Makefile ${top_builddir}/config.status
-       $(MAKE) do-build-file FILE=$@
-
-example-metadata.xml: ${srcdir}/example-metadata.xml.in Makefile ${top_builddir}/config.status
-       $(MAKE) do-build-file FILE=$@
-
 all-data-local: $(BUILTCONFIGFILES)
 
 install-data-local:    all-data-local
@@ -129,17 +115,9 @@ CLEANFILES = \
        shibd-debian \
        shibd-osx.plist \
        shibd.logger \
-       native.logger \
-       shibboleth2.xml \
-       attribute-map.xml \
-       attribute-policy.xml \
-       example-metadata.xml
+       native.logger
 
 EXTRA_DIST = \
-       shibboleth2.xml.in \
-       attribute-map.xml.in \
-       attribute-policy.xml.in \
-       example-metadata.xml.in \
        native.logger.in \
        shibd.logger.in \
        apache.config.in \