Path resolution for error templates.
[shibboleth/sp.git] / configs / Makefile.am
index 7919cac..afb642d 100644 (file)
@@ -2,15 +2,17 @@
 
 AUTOMAKE_OPTIONS = foreign
 
+pkglibdir = ${libdir}/@PACKAGE@
 pkglogdir = ${localstatedir}/log/@PACKAGE@
+pkgdocdir = ${datadir}/doc/@PACKAGE@
 shirelogdir = ${localstatedir}/log/httpd
-xmldir = $(datadir)/xml
 pkgxmldir = $(datadir)/xml/@PACKAGE@
-varrundir = $(localstatedir)/run
+pkgrundir = $(localstatedir)/run/@PACKAGE@
 pkgsysconfdir = $(sysconfdir)/@PACKAGE@
 pkgsysconf_DATA = \
        shibd-redhat \
        shibd-debian \
+       shibd-osx.plist \
        apache.config \
        apache2.config \
        apache22.config
@@ -20,16 +22,16 @@ pkgsysconf_DATA = \
 # installed as "foo" if "foo" does not already exist.  In other words,
 # the config files will not overwrite existing versions.
 BUILTCONFIGFILES = \
-       shibboleth2.xml \
        native.logger \
-       shibd.logger \
-       attribute-map.xml \
-       attribute-policy.xml \
-       example-metadata.xml
+       shibd.logger
 
 # While BUILTCONFIGFILES are processed, these are not; so we should pull
 # them from SRCDIR.
 CONFIGFILES = \
+    shibboleth2.xml \
+    attribute-map.xml \
+    attribute-policy.xml \
+    example-metadata.xml \
        console.logger \
        syslog.logger \
        accessError.html \
@@ -48,14 +50,14 @@ CONFIGFILES = \
 do-build-file:
        rm -f ${FILE}.tmp
        sed < ${srcdir}/${FILE}.in > ${FILE}.tmp \
-           -e 's:@-PREFIX-@:${prefix}:g' \
-           -e 's:@-LIBEXECDIR-@:${libexecdir}:g' \
-           -e 's:@-PKGSYSCONFDIR-@:${pkgsysconfdir}:g' \
-           -e 's:@-PKGXMLDIR-@:${pkgxmldir}:g' \
-            -e 's:@-XMLDIR-@:${xmldir}:g' \
-           -e 's:@-PKGLOGDIR-@:${pkglogdir}:g' \
-           -e 's:@-SHIRELOGDIR-@:${shirelogdir}:g' \
-           -e 's:@-VARRUNDIR-@:${varrundir}:g'
+        -e 's:@-PREFIX-@:${prefix}:g' \
+        -e 's:@-PKGLIBDIR-@:${pkglibdir}:g' \
+        -e 's:@-PKGSYSCONFDIR-@:${pkgsysconfdir}:g' \
+        -e 's:@-PKGDOCDIR-@:${pkgdocdir}:g' \
+        -e 's:@-PKGXMLDIR-@:${pkgxmldir}:g' \
+        -e 's:@-PKGLOGDIR-@:${pkglogdir}:g' \
+        -e 's:@-SHIRELOGDIR-@:${shirelogdir}:g' \
+        -e 's:@-PKGRUNDIR-@:${pkgrundir}:g'
        cmp -s ${FILE} ${FILE}.tmp || mv ${FILE}.tmp ${FILE}
        rm -f ${FILE}.tmp
 
@@ -74,32 +76,23 @@ shibd-redhat: ${srcdir}/shibd-redhat.in Makefile ${top_builddir}/config.status
 shibd-debian: ${srcdir}/shibd-debian.in Makefile ${top_builddir}/config.status
        $(MAKE) do-build-file FILE=$@
 
-shibd.logger: ${srcdir}/shibd.logger.in Makefile ${top_builddir}/config.status
-       $(MAKE) do-build-file FILE=$@
-
-native.logger: ${srcdir}/native.logger.in Makefile ${top_builddir}/config.status
-       $(MAKE) do-build-file FILE=$@
-
-shibboleth2.xml: ${srcdir}/shibboleth2.xml.in Makefile ${top_builddir}/config.status
-       $(MAKE) do-build-file FILE=$@
-
-attribute-map.xml: ${srcdir}/attribute-map.xml.in Makefile ${top_builddir}/config.status
+shibd-osx.plist: ${srcdir}/shibd-osx.plist.in Makefile ${top_builddir}/config.status
        $(MAKE) do-build-file FILE=$@
 
-attribute-policy.xml: ${srcdir}/attribute-policy.xml.in Makefile ${top_builddir}/config.status
+shibd.logger: ${srcdir}/shibd.logger.in Makefile ${top_builddir}/config.status
        $(MAKE) do-build-file FILE=$@
 
-example-metadata.xml: ${srcdir}/example-metadata.xml.in Makefile ${top_builddir}/config.status
+native.logger: ${srcdir}/native.logger.in Makefile ${top_builddir}/config.status
        $(MAKE) do-build-file FILE=$@
 
 all-data-local: $(BUILTCONFIGFILES)
 
 install-data-local:    all-data-local
        $(mkinstalldirs) $(DESTDIR)$(pkglogdir)
+       $(mkinstalldirs) $(DESTDIR)$(pkgdocdir)
        $(mkinstalldirs) $(DESTDIR)$(shirelogdir)
-       $(mkinstalldirs) $(DESTDIR)$(varrundir)
+       $(mkinstalldirs) $(DESTDIR)$(pkgrundir)
        $(mkinstalldirs) $(DESTDIR)$(pkgxmldir)
-       $(mkinstalldirs) $(DESTDIR)$(prefix)/data
        $(mkinstalldirs) $(DESTDIR)$(pkgsysconfdir)
        for f in $(BUILTCONFIGFILES); do \
                if test ! -f $(DESTDIR)${pkgsysconfdir}/$$f; then \
@@ -120,18 +113,11 @@ CLEANFILES = \
        apache22.config \
        shibd-redhat \
        shibd-debian \
+       shibd-osx.plist \
        shibd.logger \
-       native.logger \
-       shibboleth2.xml \
-       attribute-map.xml \
-       attribute-policy.xml \
-       example-metadata.xml
+       native.logger
 
 EXTRA_DIST = \
-       shibboleth2.xml.in \
-       attribute-map.xml.in \
-       attribute-policy.xml.in \
-       example-metadata.xml.in \
        native.logger.in \
        shibd.logger.in \
        apache.config.in \
@@ -139,4 +125,5 @@ EXTRA_DIST = \
        apache22.config.in \
        shibd-redhat.in \
        shibd-debian.in \
+       shibd-osx.plist.in \
        $(CONFIGFILES)