Path resolution for error templates.
[shibboleth/sp.git] / configs / Makefile.am
index cbb949f..afb642d 100644 (file)
@@ -2,12 +2,12 @@
 
 AUTOMAKE_OPTIONS = foreign
 
+pkglibdir = ${libdir}/@PACKAGE@
 pkglogdir = ${localstatedir}/log/@PACKAGE@
 pkgdocdir = ${datadir}/doc/@PACKAGE@
 shirelogdir = ${localstatedir}/log/httpd
-xmldir = $(datadir)/xml
 pkgxmldir = $(datadir)/xml/@PACKAGE@
-varrundir = $(localstatedir)/run
+pkgrundir = $(localstatedir)/run/@PACKAGE@
 pkgsysconfdir = $(sysconfdir)/@PACKAGE@
 pkgsysconf_DATA = \
        shibd-redhat \
@@ -22,16 +22,16 @@ pkgsysconf_DATA = \
 # installed as "foo" if "foo" does not already exist.  In other words,
 # the config files will not overwrite existing versions.
 BUILTCONFIGFILES = \
-       shibboleth2.xml \
        native.logger \
-       shibd.logger \
-       attribute-map.xml \
-       attribute-policy.xml \
-       example-metadata.xml
+       shibd.logger
 
 # While BUILTCONFIGFILES are processed, these are not; so we should pull
 # them from SRCDIR.
 CONFIGFILES = \
+    shibboleth2.xml \
+    attribute-map.xml \
+    attribute-policy.xml \
+    example-metadata.xml \
        console.logger \
        syslog.logger \
        accessError.html \
@@ -51,14 +51,13 @@ do-build-file:
        rm -f ${FILE}.tmp
        sed < ${srcdir}/${FILE}.in > ${FILE}.tmp \
         -e 's:@-PREFIX-@:${prefix}:g' \
-        -e 's:@-LIBEXECDIR-@:${libexecdir}:g' \
+        -e 's:@-PKGLIBDIR-@:${pkglibdir}:g' \
         -e 's:@-PKGSYSCONFDIR-@:${pkgsysconfdir}:g' \
-        -e 's:@-PKGXMLDIR-@:${pkgxmldir}:g' \
         -e 's:@-PKGDOCDIR-@:${pkgdocdir}:g' \
-        -e 's:@-XMLDIR-@:${xmldir}:g' \
+        -e 's:@-PKGXMLDIR-@:${pkgxmldir}:g' \
         -e 's:@-PKGLOGDIR-@:${pkglogdir}:g' \
         -e 's:@-SHIRELOGDIR-@:${shirelogdir}:g' \
-        -e 's:@-VARRUNDIR-@:${varrundir}:g'
+        -e 's:@-PKGRUNDIR-@:${pkgrundir}:g'
        cmp -s ${FILE} ${FILE}.tmp || mv ${FILE}.tmp ${FILE}
        rm -f ${FILE}.tmp
 
@@ -86,25 +85,13 @@ shibd.logger: ${srcdir}/shibd.logger.in Makefile ${top_builddir}/config.status
 native.logger: ${srcdir}/native.logger.in Makefile ${top_builddir}/config.status
        $(MAKE) do-build-file FILE=$@
 
-shibboleth2.xml: ${srcdir}/shibboleth2.xml.in Makefile ${top_builddir}/config.status
-       $(MAKE) do-build-file FILE=$@
-
-attribute-map.xml: ${srcdir}/attribute-map.xml.in Makefile ${top_builddir}/config.status
-       $(MAKE) do-build-file FILE=$@
-
-attribute-policy.xml: ${srcdir}/attribute-policy.xml.in Makefile ${top_builddir}/config.status
-       $(MAKE) do-build-file FILE=$@
-
-example-metadata.xml: ${srcdir}/example-metadata.xml.in Makefile ${top_builddir}/config.status
-       $(MAKE) do-build-file FILE=$@
-
 all-data-local: $(BUILTCONFIGFILES)
 
 install-data-local:    all-data-local
        $(mkinstalldirs) $(DESTDIR)$(pkglogdir)
        $(mkinstalldirs) $(DESTDIR)$(pkgdocdir)
        $(mkinstalldirs) $(DESTDIR)$(shirelogdir)
-       $(mkinstalldirs) $(DESTDIR)$(varrundir)
+       $(mkinstalldirs) $(DESTDIR)$(pkgrundir)
        $(mkinstalldirs) $(DESTDIR)$(pkgxmldir)
        $(mkinstalldirs) $(DESTDIR)$(pkgsysconfdir)
        for f in $(BUILTCONFIGFILES); do \
@@ -128,17 +115,9 @@ CLEANFILES = \
        shibd-debian \
        shibd-osx.plist \
        shibd.logger \
-       native.logger \
-       shibboleth2.xml \
-       attribute-map.xml \
-       attribute-policy.xml \
-       example-metadata.xml
+       native.logger
 
 EXTRA_DIST = \
-       shibboleth2.xml.in \
-       attribute-map.xml.in \
-       attribute-policy.xml.in \
-       example-metadata.xml.in \
        native.logger.in \
        shibd.logger.in \
        apache.config.in \