Fix separator problem.
[shibboleth/sp.git] / configs / Makefile.am
index 46c9662..ce067cc 100644 (file)
@@ -2,35 +2,61 @@
 
 AUTOMAKE_OPTIONS = foreign
 
-logdir=${pkgsysconfdir}
+pkglibdir = ${libdir}/@PACKAGE@
+pkglogdir = ${localstatedir}/log/@PACKAGE@
+pkgdocdir = ${datadir}/doc/@PACKAGE@
+shirelogdir = ${localstatedir}/log/httpd
+pkgxmldir = $(datadir)/xml/@PACKAGE@
+pkgrundir = $(localstatedir)/run/@PACKAGE@
 pkgsysconfdir = $(sysconfdir)/@PACKAGE@
 pkgsysconf_DATA = \
-       shibboleth.xml \
-       shibboleth.logger \
-       shire.logger \
-       shar.logger \
-       shar.key \
-       shar.crt \
+       shibd-redhat \
+       shibd-debian \
+       shibd-osx.plist \
        apache.config \
        apache2.config \
+       apache22.config \
+       keygen.sh
+
+# The config files are installed "special".  Unlike the entries in
+# pkgsysconf_DATA, these files are installed as "foo.dist" and only
+# installed as "foo" if "foo" does not already exist.  In other words,
+# the config files will not overwrite existing versions.
+BUILTCONFIGFILES = \
+       native.logger \
+       shibd.logger
+
+# While BUILTCONFIGFILES are processed, these are not; so we should pull
+# them from SRCDIR.
+CONFIGFILES = \
+    shibboleth2.xml \
+    attribute-map.xml \
+    attribute-policy.xml \
+    example-metadata.xml \
+       console.logger \
+       syslog.logger \
        accessError.html \
-       rmError.html \
-       shireError.html \
-       AAP.xml \
-       sites.xml \
-       trust.xml \
-       inqueue.pem
+       sessionError.html \
+       metadataError.html \
+       bindingTemplate.html \
+       localLogout.html \
+       globalLogout.html \
+       sslError.html
 
 #
 # Some of these need building
 #
 do-build-file:
        rm -f ${FILE}.tmp
-       sed < ${FILE}.in > ${FILE}.tmp \
-           -e 's:@-PREFIX-@:${prefix}:' \
-           -e 's:@-LIBEXECDIR-@:${libexecdir}:' \
-           -e 's:@-PKGSYSCONFDIR-@:${pkgsysconfdir}:' \
-           -e 's:@-LOGDIR-@:${logdir}:'
+       sed < ${srcdir}/${FILE}.in > ${FILE}.tmp \
+        -e 's:@-PREFIX-@:${prefix}:g' \
+        -e 's:@-PKGLIBDIR-@:${pkglibdir}:g' \
+        -e 's:@-PKGSYSCONFDIR-@:${pkgsysconfdir}:g' \
+        -e 's:@-PKGDOCDIR-@:${pkgdocdir}:g' \
+        -e 's:@-PKGXMLDIR-@:${pkgxmldir}:g' \
+        -e 's:@-PKGLOGDIR-@:${pkglogdir}:g' \
+        -e 's:@-SHIRELOGDIR-@:${shirelogdir}:g' \
+        -e 's:@-PKGRUNDIR-@:${pkgrundir}:g'
        cmp -s ${FILE} ${FILE}.tmp || mv ${FILE}.tmp ${FILE}
        rm -f ${FILE}.tmp
 
@@ -40,35 +66,68 @@ apache.config: ${srcdir}/apache.config.in Makefile ${top_builddir}/config.status
 apache2.config: ${srcdir}/apache2.config.in Makefile ${top_builddir}/config.status
        $(MAKE) do-build-file FILE=$@
 
-shar.logger: ${srcdir}/shar.logger.in Makefile ${top_builddir}/config.status
+apache22.config: ${srcdir}/apache22.config.in Makefile ${top_builddir}/config.status
+       $(MAKE) do-build-file FILE=$@
+
+shibd-redhat: ${srcdir}/shibd-redhat.in Makefile ${top_builddir}/config.status
+       $(MAKE) do-build-file FILE=$@
+
+shibd-debian: ${srcdir}/shibd-debian.in Makefile ${top_builddir}/config.status
        $(MAKE) do-build-file FILE=$@
 
-shire.logger: ${srcdir}/shire.logger.in Makefile ${top_builddir}/config.status
+shibd-osx.plist: ${srcdir}/shibd-osx.plist.in Makefile ${top_builddir}/config.status
        $(MAKE) do-build-file FILE=$@
 
-shibboleth.xml: ${srcdir}/shibboleth.xml.in Makefile ${top_builddir}/config.status
+shibd.logger: ${srcdir}/shibd.logger.in Makefile ${top_builddir}/config.status
        $(MAKE) do-build-file FILE=$@
 
+native.logger: ${srcdir}/native.logger.in Makefile ${top_builddir}/config.status
+       $(MAKE) do-build-file FILE=$@
+
+all-data-local: $(BUILTCONFIGFILES)
+
+install-data-local:    all-data-local
+       $(mkinstalldirs) $(DESTDIR)$(pkglogdir)
+       $(mkinstalldirs) $(DESTDIR)$(pkgdocdir)
+       $(mkinstalldirs) $(DESTDIR)$(shirelogdir)
+       $(mkinstalldirs) $(DESTDIR)$(pkgrundir)
+       $(mkinstalldirs) $(DESTDIR)$(pkgxmldir)
+       $(mkinstalldirs) $(DESTDIR)$(pkgsysconfdir)
+       for f in $(BUILTCONFIGFILES); do \
+               if test ! -f $(DESTDIR)${pkgsysconfdir}/$$f; then \
+                       $(INSTALL_DATA) $$f $(DESTDIR)${pkgsysconfdir}; \
+               fi; \
+               $(INSTALL_DATA) $$f $(DESTDIR)${pkgsysconfdir}/$$f.dist; \
+        done
+       for f in $(CONFIGFILES); do \
+               if test ! -f $(DESTDIR)${pkgsysconfdir}/$$f; then \
+                       $(INSTALL_DATA) $(srcdir)/$$f $(DESTDIR)${pkgsysconfdir}; \
+               fi; \
+               $(INSTALL_DATA) $(srcdir)/$$f $(DESTDIR)${pkgsysconfdir}/$$f.dist; \
+        done
+    if test -z $NOKEYGEN ; then
+        cd $(DESTDIR)$(pkgsysconfdir)
+        sh ./keygen.sh -b
+    fi
+
 CLEANFILES = \
        apache.config \
        apache2.config \
-       shar.logger \
-       shire.logger \
-       shibboleth.xml
-
-EXTRA_DIST = .cvsignore \
-       shibboleth.xml.in \
-       shire.logger.in \
-       shar.logger.in \
+       apache22.config \
+       shibd-redhat \
+       shibd-debian \
+       shibd-osx.plist \
+       shibd.logger \
+       native.logger
+
+EXTRA_DIST = \
+       native.logger.in \
+       shibd.logger.in \
        apache.config.in \
        apache2.config.in \
-       shibboleth.logger \
-       accessError.html \
-       rmError.html \
-       shireError.html \
-       AAP.xml \
-       sites.xml \
-       trust.xml \
-       inqueue.pem \
-       shar.key \
-       shar.crt
+       apache22.config.in \
+       shibd-redhat.in \
+       shibd-debian.in \
+       shibd-osx.plist.in \
+    keygen.bat \
+       $(CONFIGFILES)