Fix backslashes in SHIBSP_PREFIX variable by manually creating it during the script...
[shibboleth/sp.git] / configs / Makefile.am
index fb6cd71..d72363b 100644 (file)
@@ -15,7 +15,9 @@ pkgsysconf_DATA = \
        shibd-osx.plist \
        apache.config \
        apache2.config \
-       apache22.config
+       apache22.config \
+       keygen.sh \
+       upgrade.xsl
 
 # The config files are installed "special".  Unlike the entries in
 # pkgsysconf_DATA, these files are installed as "foo.dist" and only
@@ -23,26 +25,25 @@ pkgsysconf_DATA = \
 # the config files will not overwrite existing versions.
 BUILTCONFIGFILES = \
        native.logger \
-       shibd.logger \
-       attribute-map.xml \
-       attribute-policy.xml
+       shibd.logger
 
 # While BUILTCONFIGFILES are processed, these are not; so we should pull
 # them from SRCDIR.
 CONFIGFILES = \
-    shibboleth2.xml \
-    example-metadata.xml \
+       shibboleth2.xml \
+       attribute-map.xml \
+       attribute-policy.xml \
+       example-metadata.xml \
        console.logger \
        syslog.logger \
        accessError.html \
        sessionError.html \
        metadataError.html \
        bindingTemplate.html \
+       discoveryTemplate.html \
        localLogout.html \
        globalLogout.html \
-       sslError.html \
-       sp-example.key \
-       sp-example.crt
+       sslError.html
 
 #
 # Some of these need building
@@ -55,8 +56,6 @@ do-build-file:
         -e 's:@-PKGSYSCONFDIR-@:${pkgsysconfdir}:g' \
         -e 's:@-PKGDOCDIR-@:${pkgdocdir}:g' \
         -e 's:@-PKGXMLDIR-@:${pkgxmldir}:g' \
-        -e 's:@-XMLTOOLINGXMLDIR-@:${XMLTOOLINGXMLDIR}:g' \
-        -e 's:@-OPENSAMLXMLDIR-@:${OPENSAMLXMLDIR}:g' \
         -e 's:@-PKGLOGDIR-@:${pkglogdir}:g' \
         -e 's:@-SHIRELOGDIR-@:${shirelogdir}:g' \
         -e 's:@-PKGRUNDIR-@:${pkgrundir}:g'
@@ -87,12 +86,6 @@ shibd.logger: ${srcdir}/shibd.logger.in Makefile ${top_builddir}/config.status
 native.logger: ${srcdir}/native.logger.in Makefile ${top_builddir}/config.status
        $(MAKE) do-build-file FILE=$@
 
-attribute-map.xml: ${srcdir}/attribute-map.xml.in Makefile ${top_builddir}/config.status
-       $(MAKE) do-build-file FILE=$@
-
-attribute-policy.xml: ${srcdir}/attribute-policy.xml.in Makefile ${top_builddir}/config.status
-       $(MAKE) do-build-file FILE=$@
-
 all-data-local: $(BUILTCONFIGFILES)
 
 install-data-local:    all-data-local
@@ -115,6 +108,12 @@ install-data-local:        all-data-local
                $(INSTALL_DATA) $(srcdir)/$$f $(DESTDIR)${pkgsysconfdir}/$$f.dist; \
         done
 
+install-data-hook:
+       if test -z "$(NOKEYGEN)"; then \
+               cd $(DESTDIR)$(pkgsysconfdir); \
+               sh ./keygen.sh -b ; \
+       fi
+
 CLEANFILES = \
        apache.config \
        apache2.config \
@@ -123,13 +122,9 @@ CLEANFILES = \
        shibd-debian \
        shibd-osx.plist \
        shibd.logger \
-       native.logger \
-       attribute-map.xml \
-       attribute-policy.xml
+       native.logger
 
 EXTRA_DIST = \
-       attribute-map.xml.in \
-       attribute-policy.xml.in \
        native.logger.in \
        shibd.logger.in \
        apache.config.in \
@@ -138,4 +133,8 @@ EXTRA_DIST = \
        shibd-redhat.in \
        shibd-debian.in \
        shibd-osx.plist.in \
+       keygen.bat \
+       keygen.sh \
+       upgrade.xsl \
+       xsltproc.js \
        $(CONFIGFILES)