Upstream no longer install plugin .la files, so don't remove them
[shibboleth/sp.git] / configure
index 21fb8e8..7ea4018 100755 (executable)
--- a/configure
+++ b/configure
@@ -2,7 +2,7 @@
 # Guess values for system-dependent variables and create Makefiles.
 # Generated by GNU Autoconf 2.67 for shibboleth 2.5.
 #
-# Report bugs to <https://bugs.internet2.edu/>.
+# Report bugs to <https://issues.shibboleth.net/>.
 #
 #
 # Copyright (C) 1992, 1993, 1994, 1995, 1996, 1998, 1999, 2000, 2001,
@@ -239,7 +239,7 @@ fi
     $as_echo "$0: be upgraded to zsh 4.3.4 or later."
   else
     $as_echo "$0: Please tell bug-autoconf@gnu.org and
-$0: https://bugs.internet2.edu/ about your system,
+$0: https://issues.shibboleth.net/ about your system,
 $0: including any error possibly output before this
 $0: message. Then install a modern shell, or manually run
 $0: the script under such a shell if you do have one."
@@ -564,7 +564,7 @@ PACKAGE_NAME='shibboleth'
 PACKAGE_TARNAME='shibboleth'
 PACKAGE_VERSION='2.5'
 PACKAGE_STRING='shibboleth 2.5'
-PACKAGE_BUGREPORT='https://bugs.internet2.edu/'
+PACKAGE_BUGREPORT='https://issues.shibboleth.net/'
 PACKAGE_URL=''
 
 ac_unique_file="shibsp"
@@ -1573,7 +1573,7 @@ Some influential environment variables:
 Use these variables to override the choices made by `configure' or to help
 it to find libraries and programs with nonstandard names/locations.
 
-Report bugs to <https://bugs.internet2.edu/>.
+Report bugs to <https://issues.shibboleth.net/>.
 _ACEOF
 ac_status=$?
 fi
@@ -2202,9 +2202,9 @@ $as_echo "$as_me: WARNING: $2: see the Autoconf documentation" >&2;}
 $as_echo "$as_me: WARNING: $2:     section \"Present But Cannot Be Compiled\"" >&2;}
     { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: $2: proceeding with the compiler's result" >&5
 $as_echo "$as_me: WARNING: $2: proceeding with the compiler's result" >&2;}
-( $as_echo "## ------------------------------------------ ##
-## Report this to https://bugs.internet2.edu/ ##
-## ------------------------------------------ ##"
+( $as_echo "## --------------------------------------------- ##
+## Report this to https://issues.shibboleth.net/ ##
+## --------------------------------------------- ##"
      ) | sed "s/^/$as_me: WARNING:     /" >&2
     ;;
 esac
@@ -2293,9 +2293,9 @@ $as_echo "$as_me: WARNING: $2: see the Autoconf documentation" >&2;}
 $as_echo "$as_me: WARNING: $2:     section \"Present But Cannot Be Compiled\"" >&2;}
     { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: $2: proceeding with the compiler's result" >&5
 $as_echo "$as_me: WARNING: $2: proceeding with the compiler's result" >&2;}
-( $as_echo "## ------------------------------------------ ##
-## Report this to https://bugs.internet2.edu/ ##
-## ------------------------------------------ ##"
+( $as_echo "## --------------------------------------------- ##
+## Report this to https://issues.shibboleth.net/ ##
+## --------------------------------------------- ##"
      ) | sed "s/^/$as_me: WARNING:     /" >&2
     ;;
 esac
@@ -13660,7 +13660,7 @@ fi
 
 ac_config_headers="$ac_config_headers config.h shibsp/config_pub.h"
 
-ac_config_files="$ac_config_files shibboleth.spec pkginfo Portfile"
+ac_config_files="$ac_config_files shibboleth.spec"
 
 
 ac_ext=c
@@ -18032,19 +18032,20 @@ $as_echo "#define STRERROR_R_CHAR_P 1" >>confdefs.h
 
 fi
 
-for ac_header in sys/utsname.h
+for ac_header in sys/utsname.h grp.h pwd.h
 do :
-  ac_fn_c_check_header_mongrel "$LINENO" "sys/utsname.h" "ac_cv_header_sys_utsname_h" "$ac_includes_default"
-if test "x$ac_cv_header_sys_utsname_h" = x""yes; then :
+  as_ac_Header=`$as_echo "ac_cv_header_$ac_header" | $as_tr_sh`
+ac_fn_c_check_header_mongrel "$LINENO" "$ac_header" "$as_ac_Header" "$ac_includes_default"
+if eval test \"x\$"$as_ac_Header"\" = x"yes"; then :
   cat >>confdefs.h <<_ACEOF
-#define HAVE_SYS_UTSNAME_H 1
+#define `$as_echo "HAVE_$ac_header" | $as_tr_cpp` 1
 _ACEOF
 
 fi
 
 done
 
-for ac_func in strchr strdup strstr timegm gmtime_r strtok_r strcasecmp
+for ac_func in strchr strdup strstr timegm gmtime_r strtok_r strcasecmp getpwnam getgrnam
 do :
   as_ac_var=`$as_echo "ac_cv_func_$ac_func" | $as_tr_sh`
 ac_fn_c_check_func "$LINENO" "$ac_func" "$as_ac_var"
@@ -19092,7 +19093,7 @@ main ()
 #if _XMLTOOLING_VERSION >= 10500
 xmltooling::XMLToolingConfig::getConfig();
 #else
-#error Need XMLTooling version 1.4 or higher
+#error Need XMLTooling version 1.5 or higher
 #endif
   ;
   return 0;
@@ -19162,7 +19163,7 @@ main ()
 #if _OPENSAML_VERSION >= 20500
 opensaml::SAMLConfig::getConfig();
 #else
-#error Need OpenSAML version 2.4 or higher
+#error Need OpenSAML version 2.5 or higher
 #endif
   ;
   return 0;
@@ -21481,7 +21482,7 @@ $config_headers
 Configuration commands:
 $config_commands
 
-Report bugs to <https://bugs.internet2.edu/>."
+Report bugs to <https://issues.shibboleth.net/>."
 
 _ACEOF
 cat >>$CONFIG_STATUS <<_ACEOF || ac_write_fail=1
@@ -21998,8 +21999,6 @@ do
     "config.h") CONFIG_HEADERS="$CONFIG_HEADERS config.h" ;;
     "shibsp/config_pub.h") CONFIG_HEADERS="$CONFIG_HEADERS shibsp/config_pub.h" ;;
     "shibboleth.spec") CONFIG_FILES="$CONFIG_FILES shibboleth.spec" ;;
-    "pkginfo") CONFIG_FILES="$CONFIG_FILES pkginfo" ;;
-    "Portfile") CONFIG_FILES="$CONFIG_FILES Portfile" ;;
     "Makefile") CONFIG_FILES="$CONFIG_FILES Makefile" ;;
     "doc/Makefile") CONFIG_FILES="$CONFIG_FILES doc/Makefile" ;;
     "schemas/Makefile") CONFIG_FILES="$CONFIG_FILES schemas/Makefile" ;;