Port fastcgi code to trunk.
[shibboleth/sp.git] / fastcgi / Makefile.am
diff --git a/fastcgi/Makefile.am b/fastcgi/Makefile.am
new file mode 100644 (file)
index 0000000..ba460a2
--- /dev/null
@@ -0,0 +1,23 @@
+AUTOMAKE_OPTIONS = foreign\r
+\r
+if BUILD_FASTCGI\r
+\r
+fastcgidir = $(libdir)/@PACKAGE@\r
+\r
+fastcgi_PROGRAMS = shibauthorizer shibresponder\r
+\r
+shibauthorizer_SOURCES = shibauthorizer.cpp\r
+shibauthorizer_CXXFLAGS = -I$(FASTCGI_INCLUDE)\r
+shibauthorizer_LDFLAGS = $(FASTCGI_LDFLAGS) $(FASTCGI_LIBS)\r
+shibauthorizer_LDADD = \\r
+  $(top_builddir)/shibsp/libshibsp-lite.la\r
+\r
+shibresponder_SOURCES = shibresponder.cpp\r
+shibresponder_CXXFLAGS = -I$(FASTCGI_INCLUDE)\r
+shibresponder_LDFLAGS = $(FASTCGI_LDFLAGS) $(FASTCGI_LIBS)\r
+shibresponder_LDADD = \\r
+  $(top_builddir)/shibsp/libshibsp-lite.la\r
+\r
+endif\r
+\r
+EXTRA_DIST = shibauthorizer.cpp shibresponder.cpp shibauthorizer.vcproj shibresponder.vcproj\r