Merge commit '2.5.0' into moonshot-packaging-fixes
[shibboleth/sp.git] / nsapi_shib / Makefile.am
index f9af5b5..32827a4 100644 (file)
@@ -1,7 +1,7 @@
 AUTOMAKE_OPTIONS = foreign
 
 if BUILD_NSAPI
-nsapi_shibdir = $(libdir)/@PACKAGE@
+nsapi_shibdir = $(libdir)/@PACKAGE_NAME@
 nsapi_shib_LTLIBRARIES = nsapi_shib.la
 nsapi_shib_la_SOURCES = nsapi_shib.cpp
 nsapi_shib_la_CXXFLAGS = $(NSAPI_INCLUDE)
@@ -9,7 +9,7 @@ nsapi_shib_la_LDFLAGS = -module -avoid-version
 nsapi_shib_la_LIBADD = $(LITE_LIBS) \
   $(top_builddir)/shibsp/libshibsp-lite.la
 
-install-exec-hook:
+install-data-hook:
        for la in $(nsapi_shib_LTLIBRARIES) ; do rm -f $(DESTDIR)$(nsapi_shibdir)/$$la ; done
 
 endif