Fix backslashes in SHIBSP_PREFIX variable by manually creating it during the script...
[shibboleth/sp.git] / nsapi_shib / Makefile.am
index 8362f1f..82c65c0 100644 (file)
@@ -1,13 +1,13 @@
 AUTOMAKE_OPTIONS = foreign
 
 if BUILD_NSAPI
-nsapi_shibdir = $(libexecdir)
+nsapi_shibdir = $(libdir)/@PACKAGE@
 nsapi_shib_LTLIBRARIES = nsapi_shib.la
 nsapi_shib_la_SOURCES = nsapi_shib.cpp
 nsapi_shib_la_CXXFLAGS = $(NSAPI_INCLUDE)
 nsapi_shib_la_LDFLAGS = $(LITE_LIBS) -module -avoid-version
 nsapi_shib_la_LIBADD = \
-  $(top_builddir)/shibsp/libshibsp.la
+  $(top_builddir)/shibsp/libshibsp-lite.la
 
 install-exec-hook:
        for la in $(nsapi_shib_LTLIBRARIES) ; do rm -f $(DESTDIR)$(nsapi_shibdir)/$$la ; done
@@ -15,4 +15,3 @@ install-exec-hook:
 endif
 
 EXTRA_DIST = nsapi_shib.vcproj resource.h nsapi_shib.rc nsapi_shib.cpp
-