Fix backslashes in SHIBSP_PREFIX variable by manually creating it during the script...
[shibboleth/sp.git] / schemas / Makefile.am
index ed57c54..abc985f 100644 (file)
@@ -4,16 +4,20 @@ AUTOMAKE_OPTIONS = foreign
 
 pkgxmldir = $(datadir)/xml/@PACKAGE@
 
+schemafiles = \
+    shibboleth.xsd \
+    shibboleth-metadata-1.0.xsd \
+    shibboleth-2.0-native-sp-config.xsd \
+    shibboleth-2.0-afp.xsd \
+    shibboleth-2.0-afp-mf-basic.xsd \
+    shibboleth-2.0-afp-mf-saml.xsd \
+    shibboleth-2.0-attribute-map.xsd \
+    shibboleth-2.0-sp-notify.xsd \
+    WS-Trust.xsd
+
 pkgxml_DATA = \
        catalog.xml \
-    shibboleth-metadata-1.0.xsd \
-    shibboleth-spconfig-2.0.xsd \
-            shibboleth.xsd \
-                       metadata_v12_to_v11.xsl \
-                       metadata_v12_to_v13.xsl \
-                       metadata_v13_to_v12.xsl \
-                       trust_v12_to_v11.xsl \
-                       trust_v13_to_v12.xsl
+       $(schemafiles)
 
 #
 # Some of these need building
@@ -21,7 +25,7 @@ pkgxml_DATA = \
 do-build-file:
        rm -f ${FILE}.tmp
        sed < ${srcdir}/${FILE}.in > ${FILE}.tmp \
-           -e 's:@-PKGXMLDIR-@:${pkgxmldir}:'
+           -e 's:@-PKGXMLDIR-@:${pkgxmldir}:g'
        cmp -s ${FILE} ${FILE}.tmp || mv ${FILE}.tmp ${FILE}
        rm -f ${FILE}.tmp
 
@@ -30,4 +34,5 @@ catalog.xml: ${srcdir}/catalog.xml.in Makefile ${top_builddir}/config.status
 
 CLEANFILES = catalog.xml
 
-EXTRA_DIST = catalog.xml.in
+EXTRA_DIST = catalog.xml.in \
+       $(schemafiles)