First pass at some SELinux policies for the Shibboleth SP.
[shibboleth/sp.git] / selinux / Makefile.am
diff --git a/selinux/Makefile.am b/selinux/Makefile.am
new file mode 100644 (file)
index 0000000..c13c06e
--- /dev/null
@@ -0,0 +1,21 @@
+## $Id$ 
+
+AUTOMAKE_OPTIONS = foreign
+
+varrundir = /var/run
+BUILDFILES = shibshar.fc
+CLEANFILES = $(BUILDFILES)
+
+all-data-local: $(BUILDFILES)
+
+install-data-local:    all-data-local
+
+shibshar.fc: ${srcdir}/shibshar.fc.in Makefile ${top_builddir}/config.status
+       rm -f $@.tmp
+       sed < ${srcdir}/$@.in > $@.tmp \
+           -e 's:@-SBINDIR-@:${sbindir}:' \
+           -e 's:@-VARRUNDIR-@:${varrundir}:'
+       cmp -s $@ $@.tmp || mv $@.tmp $@
+       rm -f $@.tmp
+
+EXTRA_DIST = .cvsignore shibshar.fc.in shibshar.te