Upstream no longer install plugin .la files, so don't remove them
[shibboleth/sp.git] / shibboleth.spec.in
index 5be2b39..90882f5 100644 (file)
@@ -3,9 +3,9 @@ Version:        @PACKAGE_VERSION@
 Release:       1
 Summary:       Open source system for attribute-based Web SSO
 Group:         Productivity/Networking/Security
-Vendor:                Internet2
+Vendor:                Shibboleth Consortium
 License:       Apache 2.0
-URL:           http://shibboleth.internet2.edu/
+URL:           http://shibboleth.net/
 Source:                %{name}-%{version}.tar.gz
 BuildRoot:     %{_tmppath}/%{name}-%{version}-root
 Obsoletes:     @PACKAGE_NAME@ < %{version}-%{release}
@@ -20,12 +20,10 @@ BuildRequires:      libxerces-c-devel >= 2.8.0
 BuildRequires: libxml-security-c-devel >= 1.4.0
 BuildRequires: libxmltooling-devel >= 1.5
 BuildRequires: libsaml-devel >= 2.5
+BuildRequires: krb5-moonshot-devel
+
 %{?_with_log4cpp:BuildRequires: liblog4cpp-devel >= 1.0}
 %{!?_with_log4cpp:BuildRequires: liblog4shib-devel >= 1.0.4}
-%if 0%{?rhel} >= 6 || 0%{?centos_version} >= 600
-Requires:              libcurl-openssl >= 7.21.7
-BuildRequires: chrpath
-%endif
 BuildRequires:  gcc-c++, zlib-devel, boost-devel >= 1.32.0
 %{!?_without_doxygen:BuildRequires: doxygen}
 %{!?_without_odbc:BuildRequires:unixODBC-devel}
@@ -65,6 +63,7 @@ daemon, default plugins, and Apache module(s).
 Summary:       Shibboleth Development Headers
 Group:         Development/Libraries/C and C++
 Requires:      %{name} = %{version}-%{release}
+Obsoletes:     shibboleth-devel < %{version}-%{release}
 %if 0%{?suse_version} > 1030 && 0%{?suse_version} < 1130
 Requires:      libXerces-c-devel >= 2.8.0
 %else
@@ -87,11 +86,7 @@ This package includes files needed for development with Shibboleth.
 %setup -q
 
 %build
-%if 0%{?centos_version} >= 600
-       %configure %{?_without_odbc:--disable-odbc} %{?_without_adfs:--disable-adfs} %{?_with_fastcgi} %{!?_without_memcached:--with-memcached} %{?shib_options}
-%else
-       %configure %{?_without_odbc:--disable-odbc} %{?_without_adfs:--disable-adfs} %{?_with_fastcgi} %{?_with_memcached} %{?shib_options}
-%endif
+%configure %{?_without_odbc:--disable-odbc} %{?_without_adfs:--disable-adfs} %{?_with_fastcgi} %{?_with_memcached} %{?shib_options} --with-gssapi=%{_prefix} --with-xmltooling=%{_prefix}
 %{__make} pkgdocdir=%{pkgdocdir}
 
 %install
@@ -153,17 +148,6 @@ if [ "$SYSCONFIG_SHIBD" != "no" ] ; then
 # User account for shibd
 SHIBD_USER=%{runuser}
 EOF
-       %if 0%{?rhel} >= 6 || 0%{?centos_version} >= 600
-               cat >> $SYSCONFIG_SHIBD <<EOF
-
-# Override OS-supplied libcurl
-export LD_LIBRARY_PATH=/opt/shibboleth/%{_lib}
-EOF
-               # Strip existing rpath to libcurl.
-               chrpath -d $RPM_BUILD_ROOT%{_sbindir}/shibd
-               chrpath -d $RPM_BUILD_ROOT%{_bindir}/mdquery
-               chrpath -d $RPM_BUILD_ROOT%{_bindir}/resolvertest
-       %endif
 fi
 
 %if "%{_vendor}" == "redhat" || "%{_vendor}" == "suse"
@@ -226,15 +210,6 @@ fi
 
        # This adds the proper /etc/rc*.d links for the script
        /sbin/chkconfig --add shibd
-
-       # On upgrade, restart components if they're already running.
-       # This gets repeated now down in %postun, and the next release
-       # should remove this copy. If we yank it now, we'll break upgrades.
-       if [ "$1" -gt "1" ] ; then
-               /etc/init.d/shibd status 1>/dev/null && /etc/init.d/shibd restart 1>/dev/null
-               %{!?_without_builtinapache:/etc/init.d/httpd status 1>/dev/null && /etc/init.d/httpd restart 1>/dev/null}
-               exit 0
-       fi
 %endif
 %if "%{_vendor}" == "suse"
        # This adds the proper /etc/rc*.d links for the script