Forgot to add to makefile.
[shibboleth/sp.git] / shibsp / Makefile.am
index 57a8206..1b77187 100644 (file)
@@ -37,6 +37,7 @@ libshibspinclude_HEADERS = \
        RequestMapper.h \
        ServiceProvider.h \
        SessionCache.h \
+       SessionCacheEx.h \
        SPConfig.h \
        SPRequest.h \
        TransactionLog.h \
@@ -126,6 +127,7 @@ common_sources = \
        handler/impl/SAMLDSSessionInitiator.cpp \
        handler/impl/SessionInitiator.cpp \
        handler/impl/Shib1SessionInitiator.cpp \
+       handler/impl/TransformSessionInitiator.cpp \
        handler/impl/WAYFSessionInitiator.cpp \
     impl/StorageServiceSessionCache.cpp \
        impl/XMLAccessControl.cpp \
@@ -175,6 +177,7 @@ libshibsp_la_SOURCES = \
        attribute/filtering/impl/AttributeScopeMatchesShibMDScopeFunctor.cpp \
        attribute/resolver/impl/ChainingAttributeResolver.cpp \
        attribute/resolver/impl/QueryAttributeResolver.cpp \
+       attribute/resolver/impl/ChainingAttributeExtractor.cpp \
        attribute/resolver/impl/XMLAttributeExtractor.cpp \
        binding/impl/ArtifactResolver.cpp \
        binding/impl/SOAPClient.cpp \
@@ -192,6 +195,7 @@ libshibsp_lite_la_CPPFLAGS = -DSHIBSP_LITE
 paths.h: ${srcdir}/paths.h.in Makefile ${top_builddir}/config.status
        rm -f $@.tmp
        sed < ${srcdir}/$@.in > $@.tmp \
+           -e 's:@-PREFIX-@:${prefix}:g' \
            -e 's:@-PKGSYSCONFDIR-@:${pkgsysconfdir}:g' \
            -e 's:@-PKGXMLDIR-@:${pkgxmldir}:g' \
            -e 's:@-XMLTOOLINGXMLDIR-@:${XMLTOOLINGXMLDIR}:g' \