Override default package for path resolution.
[shibboleth/sp.git] / shibsp / Makefile.am
index b851cff..cb13ffb 100644 (file)
@@ -1,7 +1,7 @@
 AUTOMAKE_OPTIONS = foreign
 
 pkgsysconfdir = $(sysconfdir)/@PACKAGE@
-xmldir = $(datadir)/xml
+pkgxmldir = $(datadir)/xml/@PACKAGE@
 
 lib_LTLIBRARIES = libshibsp.la libshibsp-lite.la
 
@@ -37,6 +37,7 @@ libshibspinclude_HEADERS = \
        RequestMapper.h \
        ServiceProvider.h \
        SessionCache.h \
+       SessionCacheEx.h \
        SPConfig.h \
        SPRequest.h \
        TransactionLog.h \
@@ -69,6 +70,7 @@ handinclude_HEADERS = \
        handler/AbstractHandler.h \
        handler/AssertionConsumerService.h \
        handler/Handler.h \
+       handler/LogoutHandler.h \
        handler/RemotedHandler.h \
        handler/SessionInitiator.h
 
@@ -102,22 +104,31 @@ common_sources = \
        AbstractSPRequest.cpp \
        Application.cpp \
        ServiceProvider.cpp \
-       SessionCache.cpp \
        SPConfig.cpp \
        attribute/Attribute.cpp \
        handler/impl/AbstractHandler.cpp \
        handler/impl/AssertionConsumerService.cpp \
        handler/impl/AssertionLookup.cpp \
+       handler/impl/ChainingLogoutInitiator.cpp \
        handler/impl/ChainingSessionInitiator.cpp \
+       handler/impl/LocalLogoutInitiator.cpp \
+       handler/impl/LogoutHandler.cpp \
+       handler/impl/MetadataGenerator.cpp \
        handler/impl/RemotedHandler.cpp \
+       handler/impl/StatusHandler.cpp \
+       handler/impl/SessionHandler.cpp \
        handler/impl/SAML1Consumer.cpp \
        handler/impl/SAML2Consumer.cpp \
        handler/impl/SAML2ArtifactResolution.cpp \
+       handler/impl/SAML2Logout.cpp \
+       handler/impl/SAML2LogoutInitiator.cpp \
+       handler/impl/SAML2NameIDMgmt.cpp \
        handler/impl/SAML2SessionInitiator.cpp \
        handler/impl/SAMLDSSessionInitiator.cpp \
        handler/impl/SessionInitiator.cpp \
        handler/impl/Shib1SessionInitiator.cpp \
        handler/impl/WAYFSessionInitiator.cpp \
+    impl/StorageServiceSessionCache.cpp \
        impl/XMLAccessControl.cpp \
        impl/XMLRequestMapper.cpp \
        impl/XMLServiceProvider.cpp \
@@ -133,7 +144,6 @@ common_sources = \
 
 libshibsp_lite_la_SOURCES = \
        ${common_sources} \
-       impl/RemotedSessionCache.cpp \
        lite/CommonDomainCookie.cpp \
        lite/SAMLConstants.cpp
 
@@ -169,7 +179,6 @@ libshibsp_la_SOURCES = \
        attribute/resolver/impl/XMLAttributeExtractor.cpp \
        binding/impl/ArtifactResolver.cpp \
        binding/impl/SOAPClient.cpp \
-       impl/StorageServiceSessionCache.cpp \
        metadata/MetadataExtImpl.cpp \
        metadata/MetadataExtSchemaValidators.cpp \
        security/PKIXTrustEngine.cpp \
@@ -178,14 +187,17 @@ libshibsp_la_SOURCES = \
 # this is different from the project version
 # http://sources.redhat.com/autobook/autobook/autobook_91.html
 libshibsp_la_LDFLAGS = $(XMLSEC_LIBS) -version-info 1:0:0
-libshibsp_lite_la_LDFLAGS = -version-info 1:0:0
+libshibsp_lite_la_LDFLAGS = $(LITE_LIBS) -version-info 1:0:0
 libshibsp_lite_la_CPPFLAGS = -DSHIBSP_LITE
 
 paths.h: ${srcdir}/paths.h.in Makefile ${top_builddir}/config.status
        rm -f $@.tmp
        sed < ${srcdir}/$@.in > $@.tmp \
+           -e 's:@-PREFIX-@:${prefix}:g' \
            -e 's:@-PKGSYSCONFDIR-@:${pkgsysconfdir}:g' \
-           -e 's:@-XMLDIR-@:${xmldir}:g'
+           -e 's:@-PKGXMLDIR-@:${pkgxmldir}:g' \
+           -e 's:@-XMLTOOLINGXMLDIR-@:${XMLTOOLINGXMLDIR}:g' \
+           -e 's:@-OPENSAMLXMLDIR-@:${OPENSAMLXMLDIR}:g'
        cmp -s $@ $@.tmp || mv $@.tmp $@
        rm -f $@.tmp