Adding RHEL build support for mod_auth_gssapi
[mod_auth_kerb.git] / mod_auth_gssapi.spec
1 Summary: GSSAPI authentication module for the Apache HTTP Server
2 Name: mod_auth_gssapi
3 Version: 1.0
4 Release: 1%{?dist
5 License: BSD
6 Group: System Environment/Daemons
7 URL: http://wiki.moonshot.ja.net/
8 Source0:        %{name}-%{version}.tar.gz
9 BuildRequires: httpd-devel, krb5-devel, libtool
10
11 %description
12 The mod_auth_gssapi package provides support for authenticating
13 users of the Apache HTTP server using the SPNEGO-based HTTP 
14 Authentication protocol defined in RFC4559.
15
16 %prep
17 %setup -q -n mod_auth_kerb-moonshot
18
19 %build
20 %configure
21 make
22
23 %install
24 rm -rf $RPM_BUILD_ROOT
25
26 # install the DSO
27 mkdir -p $RPM_BUILD_ROOT%{_libdir}/httpd/modules
28 install -m 755 .libs/mod_auth_gssapi.so $RPM_BUILD_ROOT%{_libdir}/httpd/modules
29
30 # install the conf.d fragment
31 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d
32 install -m 644 $RPM_SOURCE_DIR/mod_auth_gssapi.conf \
33    $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d/auth_gssapi.conf
34
35 rm -f $RPM_BUILD_ROOT%{_libdir}/httpd/modules/{*.la,*.so.*}
36
37 %clean
38 rm -rf $RPM_BUILD_ROOT
39
40 %files
41 %defattr(-,root,root,-)
42 %{_sysconfdir}/httpd/conf.d/auth_gssapi.conf
43 %{_libdir}/httpd/modules/*.so
44
45 %changelog
46 * Fri Jan 16 2015 Stefan Paetow <stefan.paetow@jisc.ac.uk> 1.0-1
47 - Initial build.