Add support for mechanisms with no integrity
[openssh.git] / contrib / redhat / openssh.spec
1 %define ver 5.8p2
2 %define rel 1
3
4 # OpenSSH privilege separation requires a user & group ID
5 %define sshd_uid    74
6 %define sshd_gid    74
7
8 # Version of ssh-askpass
9 %define aversion 1.2.4.1
10
11 # Do we want to disable building of x11-askpass? (1=yes 0=no)
12 %define no_x11_askpass 0
13
14 # Do we want to disable building of gnome-askpass? (1=yes 0=no)
15 %define no_gnome_askpass 0
16
17 # Do we want to link against a static libcrypto? (1=yes 0=no)
18 %define static_libcrypto 0
19
20 # Do we want smartcard support (1=yes 0=no)
21 %define scard 0
22
23 # Use GTK2 instead of GNOME in gnome-ssh-askpass
24 %define gtk2 1
25
26 # Is this build for RHL 6.x?
27 %define build6x 0
28
29 # Do we want kerberos5 support (1=yes 0=no)
30 %define kerberos5 1
31
32 # Reserve options to override askpass settings with:
33 # rpm -ba|--rebuild --define 'skip_xxx 1'
34 %{?skip_x11_askpass:%define no_x11_askpass 1}
35 %{?skip_gnome_askpass:%define no_gnome_askpass 1}
36
37 # Add option to build without GTK2 for older platforms with only GTK+.
38 # RedHat <= 7.2 and Red Hat Advanced Server 2.1 are examples.
39 # rpm -ba|--rebuild --define 'no_gtk2 1'
40 %{?no_gtk2:%define gtk2 0}
41
42 # Is this a build for RHL 6.x or earlier?
43 %{?build_6x:%define build6x 1}
44
45 # If this is RHL 6.x, the default configuration has sysconfdir in /usr/etc.
46 %if %{build6x}
47 %define _sysconfdir /etc
48 %endif
49
50 # Options for static OpenSSL link:
51 # rpm -ba|--rebuild --define "static_openssl 1"
52 %{?static_openssl:%define static_libcrypto 1}
53
54 # Options for Smartcard support: (needs libsectok and openssl-engine)
55 # rpm -ba|--rebuild --define "smartcard 1"
56 %{?smartcard:%define scard 1}
57
58 # Is this a build for the rescue CD (without PAM, with MD5)? (1=yes 0=no)
59 %define rescue 0
60 %{?build_rescue:%define rescue 1}
61
62 # Turn off some stuff for resuce builds
63 %if %{rescue}
64 %define kerberos5 0
65 %endif
66
67 Summary: The OpenSSH implementation of SSH protocol versions 1 and 2.
68 Name: openssh
69 Version: %{ver}
70 %if %{rescue}
71 Release: %{rel}rescue
72 %else
73 Release: %{rel}
74 %endif
75 URL: http://www.openssh.com/portable.html
76 Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-%{version}.tar.gz
77 %if ! %{no_x11_askpass}
78 Source1: http://www.jmknoble.net/software/x11-ssh-askpass/x11-ssh-askpass-%{aversion}.tar.gz
79 %endif
80 License: BSD
81 Group: Applications/Internet
82 BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
83 Obsoletes: ssh
84 %if %{build6x}
85 PreReq: initscripts >= 5.00
86 %else
87 PreReq: initscripts >= 5.20
88 %endif
89 BuildPreReq: perl, openssl-devel, tcp_wrappers
90 BuildPreReq: /bin/login
91 %if ! %{build6x}
92 BuildPreReq: glibc-devel, pam
93 %else
94 BuildPreReq: /usr/include/security/pam_appl.h
95 %endif
96 %if ! %{no_x11_askpass}
97 BuildPreReq: /usr/include/X11/Xlib.h
98 %endif
99 %if ! %{no_gnome_askpass}
100 BuildPreReq: pkgconfig
101 %endif
102 %if %{kerberos5}
103 BuildPreReq: krb5-devel
104 BuildPreReq: krb5-libs
105 %endif
106
107 %package clients
108 Summary: OpenSSH clients.
109 Requires: openssh = %{version}-%{release}
110 Group: Applications/Internet
111 Obsoletes: ssh-clients
112
113 %package server
114 Summary: The OpenSSH server daemon.
115 Group: System Environment/Daemons
116 Obsoletes: ssh-server
117 PreReq: openssh = %{version}-%{release}, chkconfig >= 0.9
118 %if ! %{build6x}
119 Requires: /etc/pam.d/system-auth
120 %endif
121
122 %package askpass
123 Summary: A passphrase dialog for OpenSSH and X.
124 Group: Applications/Internet
125 Requires: openssh = %{version}-%{release}
126 Obsoletes: ssh-extras
127
128 %package askpass-gnome
129 Summary: A passphrase dialog for OpenSSH, X, and GNOME.
130 Group: Applications/Internet
131 Requires: openssh = %{version}-%{release}
132 Obsoletes: ssh-extras
133
134 %description
135 SSH (Secure SHell) is a program for logging into and executing
136 commands on a remote machine. SSH is intended to replace rlogin and
137 rsh, and to provide secure encrypted communications between two
138 untrusted hosts over an insecure network. X11 connections and
139 arbitrary TCP/IP ports can also be forwarded over the secure channel.
140
141 OpenSSH is OpenBSD's version of the last free version of SSH, bringing
142 it up to date in terms of security and features, as well as removing
143 all patented algorithms to separate libraries.
144
145 This package includes the core files necessary for both the OpenSSH
146 client and server. To make this package useful, you should also
147 install openssh-clients, openssh-server, or both.
148
149 %description clients
150 OpenSSH is a free version of SSH (Secure SHell), a program for logging
151 into and executing commands on a remote machine. This package includes
152 the clients necessary to make encrypted connections to SSH servers.
153 You'll also need to install the openssh package on OpenSSH clients.
154
155 %description server
156 OpenSSH is a free version of SSH (Secure SHell), a program for logging
157 into and executing commands on a remote machine. This package contains
158 the secure shell daemon (sshd). The sshd daemon allows SSH clients to
159 securely connect to your SSH server. You also need to have the openssh
160 package installed.
161
162 %description askpass
163 OpenSSH is a free version of SSH (Secure SHell), a program for logging
164 into and executing commands on a remote machine. This package contains
165 an X11 passphrase dialog for OpenSSH.
166
167 %description askpass-gnome
168 OpenSSH is a free version of SSH (Secure SHell), a program for logging
169 into and executing commands on a remote machine. This package contains
170 an X11 passphrase dialog for OpenSSH and the GNOME GUI desktop
171 environment.
172
173 %prep
174
175 %if ! %{no_x11_askpass}
176 %setup -q -a 1
177 %else
178 %setup -q
179 %endif
180
181 %build
182 %if %{rescue}
183 CFLAGS="$RPM_OPT_FLAGS -Os"; export CFLAGS
184 %endif
185
186 %if %{kerberos5}
187 K5DIR=`rpm -ql krb5-devel | grep include/krb5.h | sed 's,\/include\/krb5.h,,'`
188 echo K5DIR=$K5DIR
189 %endif
190
191 %configure \
192         --sysconfdir=%{_sysconfdir}/ssh \
193         --libexecdir=%{_libexecdir}/openssh \
194         --datadir=%{_datadir}/openssh \
195         --with-tcp-wrappers \
196         --with-rsh=%{_bindir}/rsh \
197         --with-default-path=/usr/local/bin:/bin:/usr/bin \
198         --with-superuser-path=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin \
199         --with-privsep-path=%{_var}/empty/sshd \
200         --with-md5-passwords \
201 %if %{scard}
202         --with-smartcard \
203 %endif
204 %if %{rescue}
205         --without-pam \
206 %else
207         --with-pam \
208 %endif
209 %if %{kerberos5}
210          --with-kerberos5=$K5DIR \
211 %endif
212
213
214 %if %{static_libcrypto}
215 perl -pi -e "s|-lcrypto|%{_libdir}/libcrypto.a|g" Makefile
216 %endif
217
218 make
219
220 %if ! %{no_x11_askpass}
221 pushd x11-ssh-askpass-%{aversion}
222 %configure --libexecdir=%{_libexecdir}/openssh
223 xmkmf -a
224 make
225 popd
226 %endif
227
228 # Define a variable to toggle gnome1/gtk2 building.  This is necessary
229 # because RPM doesn't handle nested %if statements.
230 %if %{gtk2}
231         gtk2=yes
232 %else
233         gtk2=no
234 %endif
235
236 %if ! %{no_gnome_askpass}
237 pushd contrib
238 if [ $gtk2 = yes ] ; then
239         make gnome-ssh-askpass2
240         mv gnome-ssh-askpass2 gnome-ssh-askpass
241 else
242         make gnome-ssh-askpass1
243         mv gnome-ssh-askpass1 gnome-ssh-askpass
244 fi
245 popd
246 %endif
247
248 %install
249 rm -rf $RPM_BUILD_ROOT
250 mkdir -p -m755 $RPM_BUILD_ROOT%{_sysconfdir}/ssh
251 mkdir -p -m755 $RPM_BUILD_ROOT%{_libexecdir}/openssh
252 mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd
253
254 make install DESTDIR=$RPM_BUILD_ROOT
255
256 install -d $RPM_BUILD_ROOT/etc/pam.d/
257 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
258 install -d $RPM_BUILD_ROOT%{_libexecdir}/openssh
259 %if %{build6x}
260 install -m644 contrib/redhat/sshd.pam.old $RPM_BUILD_ROOT/etc/pam.d/sshd
261 %else
262 install -m644 contrib/redhat/sshd.pam     $RPM_BUILD_ROOT/etc/pam.d/sshd
263 %endif
264 install -m755 contrib/redhat/sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
265
266 %if ! %{no_x11_askpass}
267 install -s x11-ssh-askpass-%{aversion}/x11-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/x11-ssh-askpass
268 ln -s x11-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/ssh-askpass
269 %endif
270
271 %if ! %{no_gnome_askpass}
272 install -s contrib/gnome-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/gnome-ssh-askpass
273 %endif
274
275 %if ! %{scard}
276          rm -f $RPM_BUILD_ROOT/usr/share/openssh/Ssh.bin
277 %endif
278
279 %if ! %{no_gnome_askpass}
280 install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
281 install -m 755 contrib/redhat/gnome-ssh-askpass.csh $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
282 install -m 755 contrib/redhat/gnome-ssh-askpass.sh $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
283 %endif
284
285 perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/*
286
287 %clean
288 rm -rf $RPM_BUILD_ROOT
289
290 %triggerun server -- ssh-server
291 if [ "$1" != 0 -a -r /var/run/sshd.pid ] ; then
292         touch /var/run/sshd.restart
293 fi
294
295 %triggerun server -- openssh-server < 2.5.0p1
296 # Count the number of HostKey and HostDsaKey statements we have.
297 gawk    'BEGIN {IGNORECASE=1}
298          /^hostkey/ || /^hostdsakey/ {sawhostkey = sawhostkey + 1}
299          END {exit sawhostkey}' /etc/ssh/sshd_config
300 # And if we only found one, we know the client was relying on the old default
301 # behavior, which loaded the the SSH2 DSA host key when HostDsaKey wasn't
302 # specified.  Now that HostKey is used for both SSH1 and SSH2 keys, specifying
303 # one nullifies the default, which would have loaded both.
304 if [ $? -eq 1 ] ; then
305         echo HostKey /etc/ssh/ssh_host_rsa_key >> /etc/ssh/sshd_config
306         echo HostKey /etc/ssh/ssh_host_dsa_key >> /etc/ssh/sshd_config
307 fi
308
309 %triggerpostun server -- ssh-server
310 if [ "$1" != 0 ] ; then
311         /sbin/chkconfig --add sshd
312         if test -f /var/run/sshd.restart ; then
313                 rm -f /var/run/sshd.restart
314                 /sbin/service sshd start > /dev/null 2>&1 || :
315         fi
316 fi
317
318 %pre server
319 %{_sbindir}/groupadd -r -g %{sshd_gid} sshd 2>/dev/null || :
320 %{_sbindir}/useradd -d /var/empty/sshd -s /bin/false -u %{sshd_uid} \
321         -g sshd -M -r sshd 2>/dev/null || :
322
323 %post server
324 /sbin/chkconfig --add sshd
325
326 %postun server
327 /sbin/service sshd condrestart > /dev/null 2>&1 || :
328
329 %preun server
330 if [ "$1" = 0 ]
331 then
332         /sbin/service sshd stop > /dev/null 2>&1 || :
333         /sbin/chkconfig --del sshd
334 fi
335
336 %files
337 %defattr(-,root,root)
338 %doc CREDITS ChangeLog INSTALL LICENCE OVERVIEW README* PROTOCOL* TODO WARNING*
339 %attr(0755,root,root) %{_bindir}/scp
340 %attr(0644,root,root) %{_mandir}/man1/scp.1*
341 %attr(0755,root,root) %dir %{_sysconfdir}/ssh
342 %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/moduli
343 %if ! %{rescue}
344 %attr(0755,root,root) %{_bindir}/ssh-keygen
345 %attr(0644,root,root) %{_mandir}/man1/ssh-keygen.1*
346 %attr(0755,root,root) %dir %{_libexecdir}/openssh
347 %attr(4711,root,root) %{_libexecdir}/openssh/ssh-keysign
348 %attr(0755,root,root) %{_libexecdir}/openssh/ssh-pkcs11-helper
349 %attr(0644,root,root) %{_mandir}/man8/ssh-keysign.8*
350 %attr(0644,root,root) %{_mandir}/man8/ssh-pkcs11-helper.8*
351 %endif
352 %if %{scard}
353 %attr(0755,root,root) %dir %{_datadir}/openssh
354 %attr(0644,root,root) %{_datadir}/openssh/Ssh.bin
355 %endif
356
357 %files clients
358 %defattr(-,root,root)
359 %attr(0755,root,root) %{_bindir}/ssh
360 %attr(0644,root,root) %{_mandir}/man1/ssh.1*
361 %attr(0644,root,root) %{_mandir}/man5/ssh_config.5*
362 %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/ssh/ssh_config
363 %attr(-,root,root) %{_bindir}/slogin
364 %attr(-,root,root) %{_mandir}/man1/slogin.1*
365 %if ! %{rescue}
366 %attr(2755,root,nobody) %{_bindir}/ssh-agent
367 %attr(0755,root,root) %{_bindir}/ssh-add
368 %attr(0755,root,root) %{_bindir}/ssh-keyscan
369 %attr(0755,root,root) %{_bindir}/sftp
370 %attr(0644,root,root) %{_mandir}/man1/ssh-agent.1*
371 %attr(0644,root,root) %{_mandir}/man1/ssh-add.1*
372 %attr(0644,root,root) %{_mandir}/man1/ssh-keyscan.1*
373 %attr(0644,root,root) %{_mandir}/man1/sftp.1*
374 %endif
375
376 %if ! %{rescue}
377 %files server
378 %defattr(-,root,root)
379 %dir %attr(0111,root,root) %{_var}/empty/sshd
380 %attr(0755,root,root) %{_sbindir}/sshd
381 %attr(0755,root,root) %{_libexecdir}/openssh/sftp-server
382 %attr(0644,root,root) %{_mandir}/man8/sshd.8*
383 %attr(0644,root,root) %{_mandir}/man5/moduli.5*
384 %attr(0644,root,root) %{_mandir}/man5/sshd_config.5*
385 %attr(0644,root,root) %{_mandir}/man8/sftp-server.8*
386 %attr(0755,root,root) %dir %{_sysconfdir}/ssh
387 %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/sshd_config
388 %attr(0600,root,root) %config(noreplace) /etc/pam.d/sshd
389 %attr(0755,root,root) %config /etc/rc.d/init.d/sshd
390 %endif
391
392 %if ! %{no_x11_askpass}
393 %files askpass
394 %defattr(-,root,root)
395 %doc x11-ssh-askpass-%{aversion}/README
396 %doc x11-ssh-askpass-%{aversion}/ChangeLog
397 %doc x11-ssh-askpass-%{aversion}/SshAskpass*.ad
398 %attr(0755,root,root) %{_libexecdir}/openssh/ssh-askpass
399 %attr(0755,root,root) %{_libexecdir}/openssh/x11-ssh-askpass
400 %endif
401
402 %if ! %{no_gnome_askpass}
403 %files askpass-gnome
404 %defattr(-,root,root)
405 %attr(0755,root,root) %config %{_sysconfdir}/profile.d/gnome-ssh-askpass.*
406 %attr(0755,root,root) %{_libexecdir}/openssh/gnome-ssh-askpass
407 %endif
408
409 %changelog
410 * Wed Jul 14 2010 Tim Rice <tim@multitalents.net>
411 - test for skip_x11_askpass (line 77) should have been for no_x11_askpass
412
413 * Mon Jun 2 2003 Damien Miller <djm@mindrot.org>
414 - Remove noip6 option. This may be controlled at run-time in client config
415   file using new AddressFamily directive
416
417 * Mon May 12 2003 Damien Miller <djm@mindrot.org>
418 - Don't install profile.d scripts when not building with GNOME/GTK askpass
419   (patch from bet@rahul.net)
420
421 * Wed Oct 01 2002 Damien Miller <djm@mindrot.org>
422 - Install ssh-agent setgid nobody to prevent ptrace() key theft attacks
423
424 * Mon Sep 30 2002 Damien Miller <djm@mindrot.org>
425 - Use contrib/ Makefile for building askpass programs
426
427 * Fri Jun 21 2002 Damien Miller <djm@mindrot.org>
428 - Merge in spec changes from seba@iq.pl (Sebastian Pachuta)
429 - Add new {ssh,sshd}_config.5 manpages
430 - Add new ssh-keysign program and remove setuid from ssh client
431
432 * Fri May 10 2002 Damien Miller <djm@mindrot.org>
433 - Merge in spec changes from RedHat, reorgansie a little
434 - Add Privsep user, group and directory
435
436 * Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-2
437 - bump and grind (through the build system)
438
439 * Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-1
440 - require sharutils for building (mindrot #137)
441 - require db1-devel only when building for 6.x (#55105), which probably won't
442   work anyway (3.1 requires OpenSSL 0.9.6 to build), but what the heck
443 - require pam-devel by file (not by package name) again
444 - add Markus's patch to compile with OpenSSL 0.9.5a (from
445   http://bugzilla.mindrot.org/show_bug.cgi?id=141) and apply it if we're
446   building for 6.x
447
448 * Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-0
449 - update to 3.1p1
450
451 * Tue Mar  5 2002 Nalin Dahyabhai <nalin@redhat.com> SNAP-20020305
452 - update to SNAP-20020305
453 - drop debug patch, fixed upstream
454
455 * Wed Feb 20 2002 Nalin Dahyabhai <nalin@redhat.com> SNAP-20020220
456 - update to SNAP-20020220 for testing purposes (you've been warned, if there's
457   anything to be warned about, gss patches won't apply, I don't mind)
458
459 * Wed Feb 13 2002 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-3
460 - add patches from Simon Wilkinson and Nicolas Williams for GSSAPI key
461   exchange, authentication, and named key support
462
463 * Wed Jan 23 2002 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-2
464 - remove dependency on db1-devel, which has just been swallowed up whole
465   by gnome-libs-devel
466
467 * Sun Dec 29 2001 Nalin Dahyabhai <nalin@redhat.com>
468 - adjust build dependencies so that build6x actually works right (fix
469   from Hugo van der Kooij)
470
471 * Tue Dec  4 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-1
472 - update to 3.0.2p1
473
474 * Fri Nov 16 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0.1p1-1
475 - update to 3.0.1p1
476
477 * Tue Nov 13 2001 Nalin Dahyabhai <nalin@redhat.com>
478 - update to current CVS (not for use in distribution)
479
480 * Thu Nov  8 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0p1-1
481 - merge some of Damien Miller <djm@mindrot.org> changes from the upstream
482   3.0p1 spec file and init script
483
484 * Wed Nov  7 2001 Nalin Dahyabhai <nalin@redhat.com>
485 - update to 3.0p1
486 - update to x11-ssh-askpass 1.2.4.1
487 - change build dependency on a file from pam-devel to the pam-devel package
488 - replace primes with moduli
489
490 * Thu Sep 27 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-9
491 - incorporate fix from Markus Friedl's advisory for IP-based authorization bugs
492
493 * Thu Sep 13 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.9p2-8
494 - Merge changes to rescue build from current sysadmin survival cd
495
496 * Thu Sep  6 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-7
497 - fix scp's server's reporting of file sizes, and build with the proper
498   preprocessor define to get large-file capable open(), stat(), etc.
499   (sftp has been doing this correctly all along) (#51827)
500 - configure without --with-ipv4-default on RHL 7.x and newer (#45987,#52247)
501 - pull cvs patch to fix support for /etc/nologin for non-PAM logins (#47298)
502 - mark profile.d scriptlets as config files (#42337)
503 - refer to Jason Stone's mail for zsh workaround for exit-hanging quasi-bug
504 - change a couple of log() statements to debug() statements (#50751)
505 - pull cvs patch to add -t flag to sshd (#28611)
506 - clear fd_sets correctly (one bit per FD, not one byte per FD) (#43221)
507
508 * Mon Aug 20 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-6
509 - add db1-devel as a BuildPrerequisite (noted by Hans Ecke)
510
511 * Thu Aug 16 2001 Nalin Dahyabhai <nalin@redhat.com>
512 - pull cvs patch to fix remote port forwarding with protocol 2
513
514 * Thu Aug  9 2001 Nalin Dahyabhai <nalin@redhat.com>
515 - pull cvs patch to add session initialization to no-pty sessions
516 - pull cvs patch to not cut off challengeresponse auth needlessly
517 - refuse to do X11 forwarding if xauth isn't there, handy if you enable
518   it by default on a system that doesn't have X installed (#49263)
519
520 * Wed Aug  8 2001 Nalin Dahyabhai <nalin@redhat.com>
521 - don't apply patches to code we don't intend to build (spotted by Matt Galgoci)
522
523 * Mon Aug  6 2001 Nalin Dahyabhai <nalin@redhat.com>
524 - pass OPTIONS correctly to initlog (#50151)
525
526 * Wed Jul 25 2001 Nalin Dahyabhai <nalin@redhat.com>
527 - switch to x11-ssh-askpass 1.2.2
528
529 * Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
530 - rebuild in new environment
531
532 * Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
533 - disable the gssapi patch
534
535 * Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
536 - update to 2.9p2
537 - refresh to a new version of the gssapi patch
538
539 * Thu Jun  7 2001 Nalin Dahyabhai <nalin@redhat.com>
540 - change Copyright: BSD to License: BSD
541 - add Markus Friedl's unverified patch for the cookie file deletion problem
542   so that we can verify it
543 - drop patch to check if xauth is present (was folded into cookie patch)
544 - don't apply gssapi patches for the errata candidate
545 - clear supplemental groups list at startup
546
547 * Fri May 25 2001 Nalin Dahyabhai <nalin@redhat.com>
548 - fix an error parsing the new default sshd_config
549 - add a fix from Markus Friedl (via openssh-unix-dev) for ssh-keygen not
550   dealing with comments right
551
552 * Thu May 24 2001 Nalin Dahyabhai <nalin@redhat.com>
553 - add in Simon Wilkinson's GSSAPI patch to give it some testing in-house,
554   to be removed before the next beta cycle because it's a big departure
555   from the upstream version
556
557 * Thu May  3 2001 Nalin Dahyabhai <nalin@redhat.com>
558 - finish marking strings in the init script for translation
559 - modify init script to source /etc/sysconfig/sshd and pass $OPTIONS to sshd
560   at startup (change merged from openssh.com init script, originally by
561   Pekka Savola)
562 - refuse to do X11 forwarding if xauth isn't there, handy if you enable
563   it by default on a system that doesn't have X installed
564
565 * Wed May  2 2001 Nalin Dahyabhai <nalin@redhat.com>
566 - update to 2.9
567 - drop various patches that came from or went upstream or to or from CVS
568
569 * Wed Apr 18 2001 Nalin Dahyabhai <nalin@redhat.com>
570 - only require initscripts 5.00 on 6.2 (reported by Peter Bieringer)
571
572 * Sun Apr  8 2001 Preston Brown <pbrown@redhat.com>
573 - remove explicit openssl requirement, fixes builddistro issue
574 - make initscript stop() function wait until sshd really dead to avoid
575   races in condrestart
576
577 * Mon Apr  2 2001 Nalin Dahyabhai <nalin@redhat.com>
578 - mention that challengereponse supports PAM, so disabling password doesn't
579   limit users to pubkey and rsa auth (#34378)
580 - bypass the daemon() function in the init script and call initlog directly,
581   because daemon() won't start a daemon it detects is already running (like
582   open connections)
583 - require the version of openssl we had when we were built
584
585 * Fri Mar 23 2001 Nalin Dahyabhai <nalin@redhat.com>
586 - make do_pam_setcred() smart enough to know when to establish creds and
587   when to reinitialize them
588 - add in a couple of other fixes from Damien for inclusion in the errata
589
590 * Thu Mar 22 2001 Nalin Dahyabhai <nalin@redhat.com>
591 - update to 2.5.2p2
592 - call setcred() again after initgroups, because the "creds" could actually
593   be group memberships
594
595 * Tue Mar 20 2001 Nalin Dahyabhai <nalin@redhat.com>
596 - update to 2.5.2p1 (includes endianness fixes in the rijndael implementation)
597 - don't enable challenge-response by default until we find a way to not
598   have too many userauth requests (we may make up to six pubkey and up to
599   three password attempts as it is)
600 - remove build dependency on rsh to match openssh.com's packages more closely
601
602 * Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
603 - remove dependency on openssl -- would need to be too precise
604
605 * Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
606 - rebuild in new environment
607
608 * Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
609 - Revert the patch to move pam_open_session.
610 - Init script and spec file changes from Pekka Savola. (#28750)
611 - Patch sftp to recognize '-o protocol' arguments. (#29540)
612
613 * Thu Feb 22 2001 Nalin Dahyabhai <nalin@redhat.com>
614 - Chuck the closing patch.
615 - Add a trigger to add host keys for protocol 2 to the config file, now that
616   configuration file syntax requires us to specify it with HostKey if we
617   specify any other HostKey values, which we do.
618
619 * Tue Feb 20 2001 Nalin Dahyabhai <nalin@redhat.com>
620 - Redo patch to move pam_open_session after the server setuid()s to the user.
621 - Rework the nopam patch to use be picked up by autoconf.
622
623 * Mon Feb 19 2001 Nalin Dahyabhai <nalin@redhat.com>
624 - Update for 2.5.1p1.
625 - Add init script mods from Pekka Savola.
626 - Tweak the init script to match the CVS contrib script more closely.
627 - Redo patch to ssh-add to try to adding both identity and id_dsa to also try
628   adding id_rsa.
629
630 * Fri Feb 16 2001 Nalin Dahyabhai <nalin@redhat.com>
631 - Update for 2.5.0p1.
632 - Use $RPM_OPT_FLAGS instead of -O when building gnome-ssh-askpass
633 - Resync with parts of Damien Miller's openssh.spec from CVS, including
634   update of x11 askpass to 1.2.0.
635 - Only require openssl (don't prereq) because we generate keys in the init
636   script now.
637
638 * Tue Feb 13 2001 Nalin Dahyabhai <nalin@redhat.com>
639 - Don't open a PAM session until we've forked and become the user (#25690).
640 - Apply Andrew Bartlett's patch for letting pam_authenticate() know which
641   host the user is attempting a login from.
642 - Resync with parts of Damien Miller's openssh.spec from CVS.
643 - Don't expose KbdInt responses in debug messages (from CVS).
644 - Detect and handle errors in rsa_{public,private}_decrypt (from CVS).
645
646 * Wed Feb  7 2001 Trond Eivind Glomsrxd <teg@redhat.com>
647 - i18n-tweak to initscript.
648
649 * Tue Jan 23 2001 Nalin Dahyabhai <nalin@redhat.com>
650 - More gettextizing.
651 - Close all files after going into daemon mode (needs more testing).
652 - Extract patch from CVS to handle auth banners (in the client).
653 - Extract patch from CVS to handle compat weirdness.
654
655 * Fri Jan 19 2001 Nalin Dahyabhai <nalin@redhat.com>
656 - Finish with the gettextizing.
657
658 * Thu Jan 18 2001 Nalin Dahyabhai <nalin@redhat.com>
659 - Fix a bug in auth2-pam.c (#23877)
660 - Gettextize the init script.
661
662 * Wed Dec 20 2000 Nalin Dahyabhai <nalin@redhat.com>
663 - Incorporate a switch for using PAM configs for 6.x, just in case.
664
665 * Tue Dec  5 2000 Nalin Dahyabhai <nalin@redhat.com>
666 - Incorporate Bero's changes for a build specifically for rescue CDs.
667
668 * Wed Nov 29 2000 Nalin Dahyabhai <nalin@redhat.com>
669 - Don't treat pam_setcred() failure as fatal unless pam_authenticate() has
670   succeeded, to allow public-key authentication after a failure with "none"
671   authentication.  (#21268)
672
673 * Tue Nov 28 2000 Nalin Dahyabhai <nalin@redhat.com>
674 - Update to x11-askpass 1.1.1. (#21301)
675 - Don't second-guess fixpaths, which causes paths to get fixed twice. (#21290)
676
677 * Mon Nov 27 2000 Nalin Dahyabhai <nalin@redhat.com>
678 - Merge multiple PAM text messages into subsequent prompts when possible when
679   doing keyboard-interactive authentication.
680
681 * Sun Nov 26 2000 Nalin Dahyabhai <nalin@redhat.com>
682 - Disable the built-in MD5 password support.  We're using PAM.
683 - Take a crack at doing keyboard-interactive authentication with PAM, and
684   enable use of it in the default client configuration so that the client
685   will try it when the server disallows password authentication.
686 - Build with debugging flags.  Build root policies strip all binaries anyway.
687
688 * Tue Nov 21 2000 Nalin Dahyabhai <nalin@redhat.com>
689 - Use DESTDIR instead of %%makeinstall.
690 - Remove /usr/X11R6/bin from the path-fixing patch.
691
692 * Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
693 - Add the primes file from the latest snapshot to the main package (#20884).
694 - Add the dev package to the prereq list (#19984).
695 - Remove the default path and mimic login's behavior in the server itself.
696
697 * Fri Nov 17 2000 Nalin Dahyabhai <nalin@redhat.com>
698 - Resync with conditional options in Damien Miller's .spec file for an errata.
699 - Change libexecdir from %%{_libexecdir}/ssh to %%{_libexecdir}/openssh.
700
701 * Tue Nov  7 2000 Nalin Dahyabhai <nalin@redhat.com>
702 - Update to OpenSSH 2.3.0p1.
703 - Update to x11-askpass 1.1.0.
704 - Enable keyboard-interactive authentication.
705
706 * Mon Oct 30 2000 Nalin Dahyabhai <nalin@redhat.com>
707 - Update to ssh-askpass-x11 1.0.3.
708 - Change authentication related messages to be private (#19966).
709
710 * Tue Oct 10 2000 Nalin Dahyabhai <nalin@redhat.com>
711 - Patch ssh-keygen to be able to list signatures for DSA public key files
712   it generates.
713
714 * Thu Oct  5 2000 Nalin Dahyabhai <nalin@redhat.com>
715 - Add BuildPreReq on /usr/include/security/pam_appl.h to be sure we always
716   build PAM authentication in.
717 - Try setting SSH_ASKPASS if gnome-ssh-askpass is installed.
718 - Clean out no-longer-used patches.
719 - Patch ssh-add to try to add both identity and id_dsa, and to error only
720   when neither exists.
721
722 * Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
723 - Update x11-askpass to 1.0.2. (#17835)
724 - Add BuildPreReqs for /bin/login and /usr/bin/rsh so that configure will
725   always find them in the right place. (#17909)
726 - Set the default path to be the same as the one supplied by /bin/login, but
727   add /usr/X11R6/bin. (#17909)
728 - Try to handle obsoletion of ssh-server more cleanly.  Package names
729   are different, but init script name isn't. (#17865)
730
731 * Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
732 - Update to 2.2.0p1. (#17835)
733 - Tweak the init script to allow proper restarting. (#18023)
734
735 * Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
736 - Update to 20000823 snapshot.
737 - Change subpackage requirements from %%{version} to %%{version}-%%{release}
738 - Back out the pipe patch.
739
740 * Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
741 - Update to 2.1.1p4, which includes fixes for config file parsing problems.
742 - Move the init script back.
743 - Add Damien's quick fix for wackiness.
744
745 * Wed Jul 12 2000 Nalin Dahyabhai <nalin@redhat.com>
746 - Update to 2.1.1p3, which includes fixes for X11 forwarding and strtok().
747
748 * Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
749 - Move condrestart to server postun.
750 - Move key generation to init script.
751 - Actually use the right patch for moving the key generation to the init script.
752 - Clean up the init script a bit.
753
754 * Wed Jul  5 2000 Nalin Dahyabhai <nalin@redhat.com>
755 - Fix X11 forwarding, from mail post by Chan Shih-Ping Richard.
756
757 * Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
758 - Update to 2.1.1p2.
759 - Use of strtok() considered harmful.
760
761 * Sat Jul  1 2000 Nalin Dahyabhai <nalin@redhat.com>
762 - Get the build root out of the man pages.
763
764 * Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
765 - Add and use condrestart support in the init script.
766 - Add newer initscripts as a prereq.
767
768 * Tue Jun 27 2000 Nalin Dahyabhai <nalin@redhat.com>
769 - Build in new environment (release 2)
770 - Move -clients subpackage to Applications/Internet group
771
772 * Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
773 - Update to 2.2.1p1
774
775 * Sat Jun  3 2000 Nalin Dahyabhai <nalin@redhat.com>
776 - Patch to build with neither RSA nor RSAref.
777 - Miscellaneous FHS-compliance tweaks.
778 - Fix for possibly-compressed man pages.
779
780 * Wed Mar 15 2000 Damien Miller <djm@ibs.com.au>
781 - Updated for new location
782 - Updated for new gnome-ssh-askpass build
783
784 * Sun Dec 26 1999 Damien Miller <djm@mindrot.org>
785 - Added Jim Knoble's <jmknoble@pobox.com> askpass
786
787 * Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
788 - Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
789
790 * Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
791 - Added 'Obsoletes' directives
792
793 * Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
794 - Use make install
795 - Subpackages
796
797 * Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
798 - Added links for slogin
799 - Fixed perms on manpages
800
801 * Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
802 - Renamed init script
803
804 * Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
805 - Back to old binary names
806
807 * Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
808 - Use autoconf
809 - New binary names
810
811 * Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
812 - Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.