Touch up some Solaris package files for later.
[shibboleth/cpp-xmltooling.git] / dependencies / log4cpp / log4cpp.spec
1 Name:           log4cpp
2 Version:        0.3.5rc1
3 Release:        1
4 Summary:        C++ logging library
5
6 Group:          System Environment/Libraries
7 License:        LGPL
8 URL:            http://log4cpp.sourceforge.net/
9 Source0:        http://wayf.internet2.edu/shibboleth/%{name}-%{version}.tar.gz
10 Source1:        http://wayf.internet2.edu/shibboleth/%{name}-%{version}.tar.gz.asc
11 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
12
13 BuildRequires:  doxygen
14
15 %description
16 Log4cpp is library of C++ classes for flexible logging to files,
17 syslog, IDSA and other destinations. It is modeled after the Log4j
18 Java library, staying as close to their API as is reasonable.
19
20 %package        devel
21 Summary:        Development files for %{name}
22 Group:          Development/Libraries
23 Requires:       %{name} = %{version}-%{release}
24
25 %description    devel
26 Log4cpp is library of C++ classes for flexible logging to files,
27 syslog, IDSA and other destinations. It is modeled after the Log4j
28 Java library, staying as close to their API as is reasonable.
29
30 This package contains the development files for log4cpp.
31
32 %package        docs
33 Summary:        Developer documentation for %{name}
34 Group:          Documentation
35
36 %description    docs
37 Log4cpp is library of C++ classes for flexible logging to files,
38 syslog, IDSA and other destinations. It is modeled after the Log4j
39 Java library, staying as close to their API as is reasonable.
40
41 This package contains the documentation files for log4cpp.
42
43 %prep
44 %setup0 -q
45
46 %build
47 # TODO: --with-idsa
48 %configure
49 make %{?_smp_mflags}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT _docs
53 make install DESTDIR=$RPM_BUILD_ROOT docdir=/_docs
54 mv $RPM_BUILD_ROOT/_docs .
55
56 %check || :
57 make check
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %post -p /sbin/ldconfig
63 %postun -p /sbin/ldconfig
64
65 %files
66 %defattr(-,root,root,-)
67 %doc AUTHORS ChangeLog COPYING NEWS README THANKS TODO
68 %{_libdir}/*.so.*
69
70 %files devel
71 %defattr(-,root,root,-)
72 %{_bindir}/log4cpp-config
73 %{_datadir}/aclocal/log4cpp.m4
74 %{_includedir}/log4cpp
75 %{_mandir}/man3/*
76 %{_libdir}/*.so
77 %{_libdir}/*.a
78 %{_libdir}/pkgconfig/log4cpp.pc
79 %exclude %{_libdir}/*.la
80
81 %files docs
82 %defattr(-,root,root,-)
83 %doc _docs/*
84
85 %changelog
86 * Tue Oct 19 2004   Derek Atkins <derek@ihtfp.com> - 0.3.5-1
87 - First build for Shib.