758544b249dcc8bc6eba32263ec8ab4eef389117
[shibboleth/cpp-xmltooling.git] / dependencies / xerces / xerces-c.spec
1 Summary:    Xerces-C++ validating XML parser
2 Name:       xerces-c
3 Version:    3.0.1
4 Release:    1
5 URL:        http://xerces.apache.org/xerces-c/
6 Source0:    %{name}-%{version}.tar.gz
7 License:        Apache
8 Group:      Libraries
9 BuildRoot:  %{_tmppath}/%{name}-root
10 Prefix:     /usr
11 BuildRequires: gcc-c++
12 %{?_with_curl:BuildRequires: curl-devel}
13 %{?_with_icu:BuildRequires: libicu-devel}
14 %if "%{_vendor}" == "redhat"
15 BuildRequires: redhat-rpm-config
16 %endif
17
18 %description
19 Xerces-C++ is a validating XML parser written in a portable subset of C++.
20 Xerces-C++ makes it easy to give your application the ability to read and
21 write XML data. A shared library is provided for parsing, generating,
22 manipulating, and validating XML documents.
23
24 The parser provides high performance, modularity, and scalability. Source
25 code, samples and API documentation are provided with the parser. For
26 portability, care has been taken to make minimal use of templates, no RTTI,
27 and minimal use of #ifdefs.
28
29 %package devel
30 Requires:   %{name} = %{version}
31 Group:      Development/Libraries
32 Summary:    Header files for Xerces-C++ validating XML parser
33
34 %description devel
35 Header files you can use to develop XML applications with Xerces-C++.
36
37 Xerces-C++ is a validating XML parser written in a portable subset of C++.
38 Xerces-C++ makes it easy to give your application the ability to read and
39 write XML data. A shared library is provided for parsing, generating,
40 manipulating, and validating XML documents.
41
42 %prep
43 %setup -q
44
45 %build
46 %configure %{?_with_curl:--enable-netaccessor-curl} %{!?_with_curl:--disable-netaccessor-curl} %{?_with_icu:--enable-transcoder-icu --enable-msgloader-icu} %{?xerces_options}
47 %{__make}
48
49 %install
50 %{__make} install DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 [ "$RPM_BUILD_ROOT" != "/" ] && %{__rm} -rf $RPM_BUILD_ROOT
54
55 %ifnos solaris2.8 solaris2.9 solaris2.10
56 %post -p /sbin/ldconfig
57 %endif
58
59 %ifnos solaris2.8 solaris2.9 solaris2.10
60 %postun -p /sbin/ldconfig
61 %endif
62
63 %files
64 %defattr(755,root,root)
65 %{_bindir}/*
66 %{_libdir}/lib%{name}-*.so
67
68 %files devel
69 %defattr(-,root,root)
70 %{_includedir}
71 %{_libdir}/lib%{name}.so
72 %{_libdir}/lib%{name}.a
73 %{_libdir}/pkgconfig/%{name}.pc
74 %exclude %{_libdir}/lib%{name}.la
75
76 %changelog
77 * Wed Aug  5 2009 Scott Cantor <cantor.2@osu.edu> 3.0.1-1
78 - Disabled curl thanks to Red Hat
79
80 * Fri Mar  7 2008 Boris Kolpackov <boris@codesynthesis.com>
81 - Integrated updates for 3.0.0 from Scott Cantor.
82
83 * Fri Jun  6 2003 Tuan Hoang <tqhoang@bigfoot.com>
84 - updated for new Xerces-C filename and directory format
85 - fixed date format in changelog section
86
87 * Fri Mar 14 2003 Tinny Ng <tng@ca.ibm.com>
88 - changed to 2.3
89
90 * Wed Dec 18 2002 Albert Strasheim <albert@stonethree.com>
91 - added symlink to libxerces-c.so in lib directory
92
93 * Fri Dec 13 2002 Albert Strasheim <albert@stonethree.com>
94 - added seperate doc package
95 - major cleanups
96
97 * Tue Sep 03 2002  <thomas@linux.de>
98 - fixed missing DESTDIR in Makefile.util.submodule
99
100 * Mon Sep 02 2002  <thomas@linux.de>
101 - Initial build.