Update for 3.1
[shibboleth/cpp-xmltooling.git] / dependencies / xerces / xerces-c.spec
1 Summary:    Xerces-C++ validating XML parser
2 Name:       xerces-c
3 Version:    3.1.0
4 Release:    1
5 URL:        http://xerces.apache.org/xerces-c/
6 Source0:    %{name}-%{version}.tar.gz
7 License:    Apache
8 Group:      Libraries
9 BuildRoot:  %{_tmppath}/%{name}-root
10 Prefix:     /usr
11 BuildRequires: gcc-c++
12 %{?_with_curl:BuildRequires: curl-devel}
13 %{?_with_icu:BuildRequires: libicu-devel}
14 %if "%{_vendor}" == "redhat"
15 BuildRequires: redhat-rpm-config
16 %endif
17
18 %description
19 Xerces-C++ is a validating XML parser written in a portable subset of C++.
20 Xerces-C++ makes it easy to give your application the ability to read and
21 write XML data. A shared library is provided for parsing, generating,
22 manipulating, and validating XML documents.
23
24 %package -n xerces-c-bin
25 Summary:    Utilities for Xerces-C++ validating XML parser
26 Group:      Development/Libraries
27
28 %description -n xerces-c-bin
29 Xerces-C++ is a validating XML parser written in a portable subset of C++.
30 Xerces-C++ makes it easy to give your application the ability to read and
31 write XML data. A shared library is provided for parsing, generating,
32 manipulating, and validating XML documents.
33
34 This package contains the utility programs.
35
36 %package -n libxerces-c-3_1
37 Summary:    Shared library for Xerces-C++ validating XML parser
38 Group:      Development/Libraries
39 Provides:   xerces-c = %{version}
40 Obsoletes:  xerces-c
41
42 %description -n libxerces-c-3_1
43 Xerces-C++ is a validating XML parser written in a portable subset of C++.
44 Xerces-C++ makes it easy to give your application the ability to read and
45 write XML data. A shared library is provided for parsing, generating,
46 manipulating, and validating XML documents.
47
48 This package contains just the shared library.
49
50 %package -n libxerces-c-devel
51 Group:      Development/Libraries
52 Summary:    Header files for Xerces-C++ validating XML parser
53 Requires:   libxerces-c-3_1 = %{version}
54 Provides:   xerces-c-devel = %{version}
55 Obsoletes:  xerces-c-devel
56
57 %description -n libxerces-c-devel
58 Xerces-C++ is a validating XML parser written in a portable subset of C++.
59 Xerces-C++ makes it easy to give your application the ability to read and
60 write XML data. A shared library is provided for parsing, generating,
61 manipulating, and validating XML documents.
62
63 The static libraries and header files needed for development with Xerces-C++.
64
65 %prep
66 %setup -q
67
68 %build
69 %configure %{?_with_curl:--enable-netaccessor-curl} %{!?_with_curl:--disable-netaccessor-curl} %{?_with_icu:--enable-transcoder-icu --enable-msgloader-icu} %{?xerces_options}
70 %{__make}
71
72 %install
73 %{__make} install DESTDIR=$RPM_BUILD_ROOT
74
75 %clean
76 [ "$RPM_BUILD_ROOT" != "/" ] && %{__rm} -rf $RPM_BUILD_ROOT
77
78 %ifnos solaris2.8 solaris2.9 solaris2.10
79 %post -n libxerces-c-3_1 -p /sbin/ldconfig
80 %endif
81
82 %ifnos solaris2.8 solaris2.9 solaris2.10
83 %postun -n libxerces-c-3_1 -p /sbin/ldconfig
84 %endif
85
86 %files -n xerces-c-bin
87 %defattr(755,root,root)
88 %{_bindir}/*
89
90 %files -n libxerces-c-3_1
91 %defattr(755,root,root)
92 %{_libdir}/libxerces-c-*.so
93
94 %files -n libxerces-c-devel
95 %defattr(-,root,root)
96 %{_includedir}
97 %{_libdir}/libxerces-c.so
98 %{_libdir}/libxerces-c.a
99 %{_libdir}/pkgconfig/xerces-c.pc
100 %exclude %{_libdir}/libxerces-c.la
101
102 %changelog
103 * Sun Feb 14 2010 Scott Cantor <cantor.2@osu.edu> 3.1.0-1
104 - Bump version
105
106 * Mon Dec 28 2009 Scott Cantor <cantor.2@osu.edu> 3.0.1-2
107 - Sync package names for side by side installation
108
109 * Wed Aug  5 2009 Scott Cantor <cantor.2@osu.edu> 3.0.1-1
110 - Disabled curl thanks to Red Hat
111
112 * Fri Mar  7 2008 Boris Kolpackov <boris@codesynthesis.com>
113 - Integrated updates for 3.0.0 from Scott Cantor.
114
115 * Fri Jun  6 2003 Tuan Hoang <tqhoang@bigfoot.com>
116 - updated for new Xerces-C filename and directory format
117 - fixed date format in changelog section
118
119 * Fri Mar 14 2003 Tinny Ng <tng@ca.ibm.com>
120 - changed to 2.3
121
122 * Wed Dec 18 2002 Albert Strasheim <albert@stonethree.com>
123 - added symlink to libxerces-c.so in lib directory
124
125 * Fri Dec 13 2002 Albert Strasheim <albert@stonethree.com>
126 - added seperate doc package
127 - major cleanups
128
129 * Tue Sep 03 2002  <thomas@linux.de>
130 - fixed missing DESTDIR in Makefile.util.submodule
131
132 * Mon Sep 02 2002  <thomas@linux.de>
133 - Initial build.