Private copy of spec file to disable curl use.
[shibboleth/cpp-xmltooling.git] / dependencies / xerces / xerces-c.spec
1 Summary:    Xerces-C++ validating XML parser
2 Name:       xerces-c
3 Version:    3.0.1
4 Release:    1
5 URL:        http://xerces.apache.org/xerces-c/
6 Source0:    %{name}-%{version}.tar.gz
7 License:        Apache
8 Group:      Libraries
9 BuildRoot:  %{_tmppath}/%{name}-root
10 Prefix:     /usr
11 BuildRequires: gcc-c++
12 %{?_with_curl:BuildRequires: curl-devel}
13 %{?_with_icu:BuildRequires: libicu-devel}
14
15
16 %description
17 Xerces-C++ is a validating XML parser written in a portable subset of C++.
18 Xerces-C++ makes it easy to give your application the ability to read and
19 write XML data. A shared library is provided for parsing, generating,
20 manipulating, and validating XML documents.
21
22 The parser provides high performance, modularity, and scalability. Source
23 code, samples and API documentation are provided with the parser. For
24 portability, care has been taken to make minimal use of templates, no RTTI,
25 and minimal use of #ifdefs.
26
27 %package devel
28 Requires:   %{name} = %{version}
29 Group:      Development/Libraries
30 Summary:    Header files for Xerces-C++ validating XML parser
31
32 %description devel
33 Header files you can use to develop XML applications with Xerces-C++.
34
35 Xerces-C++ is a validating XML parser written in a portable subset of C++.
36 Xerces-C++ makes it easy to give your application the ability to read and
37 write XML data. A shared library is provided for parsing, generating,
38 manipulating, and validating XML documents.
39
40 %prep
41 %setup -q
42
43 %build
44 %configure %{?_with_curl:--enable-netaccessor-curl} %{!?_with_curl:--disable-netaccessor-curl} %{?_with_icu:--enable-transcoder-icu --enable-msgloader-icu} %{?xerces_options}
45 %{__make}
46
47 %install
48 %{__make} install DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 [ "$RPM_BUILD_ROOT" != "/" ] && %{__rm} -rf $RPM_BUILD_ROOT
52
53 %ifnos solaris2.8 solaris2.9 solaris2.10
54 %post -p /sbin/ldconfig
55 %endif
56
57 %ifnos solaris2.8 solaris2.9 solaris2.10
58 %postun -p /sbin/ldconfig
59 %endif
60
61 %files
62 %defattr(755,root,root)
63 %{_bindir}/*
64 %{_libdir}/lib%{name}-*.so
65
66 %files devel
67 %defattr(-,root,root)
68 %{_includedir}
69 %{_libdir}/lib%{name}.so
70 %{_libdir}/lib%{name}.a
71 %{_libdir}/pkgconfig/%{name}.pc
72 %exclude %{_libdir}/lib%{name}.la
73
74 %changelog
75 * Wed Aug  5 2009 Scott Cantor <cantor.2@osu.edu> 3.0.1-1
76 - Disabled curl thanks to Red Hat
77
78 * Fri Mar  7 2008 Boris Kolpackov <boris@codesynthesis.com>
79 - Integrated updates for 3.0.0 from Scott Cantor.
80
81 * Fri Jun  6 2003 Tuan Hoang <tqhoang@bigfoot.com>
82 - updated for new Xerces-C filename and directory format
83 - fixed date format in changelog section
84
85 * Fri Mar 14 2003 Tinny Ng <tng@ca.ibm.com>
86 - changed to 2.3
87
88 * Wed Dec 18 2002 Albert Strasheim <albert@stonethree.com>
89 - added symlink to libxerces-c.so in lib directory
90
91 * Fri Dec 13 2002 Albert Strasheim <albert@stonethree.com>
92 - added seperate doc package
93 - major cleanups
94
95 * Tue Sep 03 2002  <thomas@linux.de>
96 - fixed missing DESTDIR in Makefile.util.submodule
97
98 * Mon Sep 02 2002  <thomas@linux.de>
99 - Initial build.