Alter package names to support side by side installs.
[shibboleth/cpp-xmltooling.git] / dependencies / xerces / xerces-c.spec
1 Summary:    Xerces-C++ validating XML parser
2 Name:       xerces-c
3 Version:    3.0.1
4 Release:    2
5 URL:        http://xerces.apache.org/xerces-c/
6 Source0:    %{name}-%{version}.tar.gz
7 License:    Apache
8 Group:      Libraries
9 BuildRoot:  %{_tmppath}/%{name}-root
10 Prefix:     /usr
11 BuildRequires: gcc-c++
12 %{?_with_curl:BuildRequires: curl-devel}
13 %{?_with_icu:BuildRequires: libicu-devel}
14 %if "%{_vendor}" == "redhat"
15 BuildRequires: redhat-rpm-config
16 %endif
17
18 %description
19 Xerces-C++ is a validating XML parser written in a portable subset of C++.
20 Xerces-C++ makes it easy to give your application the ability to read and
21 write XML data. A shared library is provided for parsing, generating,
22 manipulating, and validating XML documents.
23
24 %package -n libxerces-c-3_0
25 Summary:    Log for C++, Shibboleth Edition
26 Group:      Development/Libraries
27 Provides:   xerces-c = %{version}
28 Obsoletes:  xerces-c
29
30 %description -n libxerces-c-3_0
31 Xerces-C++ is a validating XML parser written in a portable subset of C++.
32 Xerces-C++ makes it easy to give your application the ability to read and
33 write XML data. A shared library is provided for parsing, generating,
34 manipulating, and validating XML documents.
35
36 This package contains just the shared library.
37
38 %package -n libxerces-c-devel
39 Group:      Development/Libraries
40 Summary:    Header files for Xerces-C++ validating XML parser
41 Requires:   libxerces-c-3_0 = %{version}
42 Provides:   xerces-c-devel = %{version}
43 Obsoletes:  xerces-c-devel
44
45 %description -n libxerces-c-devel
46 Xerces-C++ is a validating XML parser written in a portable subset of C++.
47 Xerces-C++ makes it easy to give your application the ability to read and
48 write XML data. A shared library is provided for parsing, generating,
49 manipulating, and validating XML documents.
50
51 The static libraries and header files needed for development with Xerces-C++.
52
53 %prep
54 %setup -q
55
56 %build
57 %configure %{?_with_curl:--enable-netaccessor-curl} %{!?_with_curl:--disable-netaccessor-curl} %{?_with_icu:--enable-transcoder-icu --enable-msgloader-icu} %{?xerces_options}
58 %{__make}
59
60 %install
61 %{__make} install DESTDIR=$RPM_BUILD_ROOT
62
63 %clean
64 [ "$RPM_BUILD_ROOT" != "/" ] && %{__rm} -rf $RPM_BUILD_ROOT
65
66 %ifnos solaris2.8 solaris2.9 solaris2.10
67 %post -n libxerces-c-3_0 -p /sbin/ldconfig
68 %endif
69
70 %ifnos solaris2.8 solaris2.9 solaris2.10
71 %postun -n libxerces-c-3_0 -p /sbin/ldconfig
72 %endif
73
74 %files
75 %defattr(755,root,root)
76 %{_bindir}/*
77
78 %files -n libxerces-c-3_0
79 %defattr(755,root,root)
80 %{_libdir}/libxerces-c-*.so
81
82 %files -n libxerces-c-devel
83 %defattr(-,root,root)
84 %{_includedir}
85 %{_libdir}/libxerces-c.so
86 %{_libdir}/libxerces-c.a
87 %{_libdir}/pkgconfig/xerces-c.pc
88 %exclude %{_libdir}/libxerces-c.la
89
90 %changelog
91 * Mon Dec 28 2009 Scott Cantor <cantor.2@osu.edu> 3.0.1-2
92 - Sync package names for side by side installation
93
94 * Wed Aug  5 2009 Scott Cantor <cantor.2@osu.edu> 3.0.1-1
95 - Disabled curl thanks to Red Hat
96
97 * Fri Mar  7 2008 Boris Kolpackov <boris@codesynthesis.com>
98 - Integrated updates for 3.0.0 from Scott Cantor.
99
100 * Fri Jun  6 2003 Tuan Hoang <tqhoang@bigfoot.com>
101 - updated for new Xerces-C filename and directory format
102 - fixed date format in changelog section
103
104 * Fri Mar 14 2003 Tinny Ng <tng@ca.ibm.com>
105 - changed to 2.3
106
107 * Wed Dec 18 2002 Albert Strasheim <albert@stonethree.com>
108 - added symlink to libxerces-c.so in lib directory
109
110 * Fri Dec 13 2002 Albert Strasheim <albert@stonethree.com>
111 - added seperate doc package
112 - major cleanups
113
114 * Tue Sep 03 2002  <thomas@linux.de>
115 - fixed missing DESTDIR in Makefile.util.submodule
116
117 * Mon Sep 02 2002  <thomas@linux.de>
118 - Initial build.