Dependency packaging files.
[shibboleth/cpp-xmltooling.git] / dependencies / xml-security / xml-security-c.spec
1 Name:           xml-security-c
2 Version:        1.3.1
3 Release:        1
4 Summary:        C++ XML security library
5
6 Group:          System Environment/Libraries
7 License:        Apache Software License
8 URL:            http://xml.apache.org/security/c/
9 Source0:        http://xml.apache.org/security/dist/c-library/%{name}-%{version}.tar.gz
10 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
11
12 BuildRequires:  xerces%{?xercesver}-c-devel >= 2.3, openssl-devel
13 %{?_with_xalan:BuildRequires: xalan-c-devel >= 1.6}
14
15 %description
16 The Apache %{summary}.
17
18 Non-default rpmbuild options:
19 "--with xalan":   use the Xalan XSLT processor.
20
21 %package        devel
22 Summary:        Development files for the Apache C++ XML security library
23 Group:          Development/Libraries
24 Requires:       %{name} = %{version}-%{release}
25
26 %description    devel
27 %{summary}.
28
29 %package        docs
30 Summary:        Developer documentation for the Apache C++ XML security library
31 Group:          Documentation
32
33 %description    docs
34 %{summary}.
35
36
37 %prep
38 %setup0 -q
39
40 %build
41 %configure %{!?_with_xalan: --without-xalan}
42 make # %{?_smp_mflags} # fails as of 1.[01].0.
43
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 mkdir -pm 755 $RPM_BUILD_ROOT%{_libdir} # FIXME in Makefiles
48 make install DESTDIR=$RPM_BUILD_ROOT
49
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54
55 %post -p /sbin/ldconfig
56 %postun -p /sbin/ldconfig
57
58
59 %files
60 %defattr(-,root,root,-)
61 %doc LICENSE NOTICE
62 %{_libdir}/*.so.*
63 %{_libdir}/*.a
64 %exclude %{_libdir}/*.la
65 %{_bindir}/*
66
67 %files devel
68 %defattr(-,root,root,-)
69 %{_includedir}/xsec
70 %{_libdir}/*.so
71
72 %files docs
73 %defattr(644,root,root,755)
74 %doc doc/c/*
75
76
77 %changelog
78 * Mon Jun 11 2007   Scott Cantor  <cantor.2@osu.edu> 1.3.1-1
79 - update to 1.3.1
80 * Thu Mar 23 2006   Ian Young     <ian@iay.org.uk> - 1.2.0-2
81 - patch to remove extra qualifications for compat with g++ 4.1
82 * Sun Jul 03 2005   Scott Cantor  <cantor.2@osu.edu> - 1.2.0-1
83 - Updated version.
84 * Mon Oct 19 2004   Derek Atkins  <derek@ihtfp.com> - 1.1.1-1
85 - First Package.