Convince Centos not to override -Wno-parenthesis
[trust_router.git] / trust_router.spec
1 %global optflags %{optflags} -Wno-parentheses
2 Name:           trust_router
3 Version:        1.3
4 Release:        1%{?dist}
5 Summary:        Moonshot Trust Router
6
7 Group:          System Environment/Libraries
8 License:        BSD
9 URL:            http://www.project-moonshot.org/
10 Source0:        %{name}-%{version}.tar.gz
11 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
12
13 BuildRequires:  krb5-devel 
14 BuildRequires: jansson-devel >= 2.4
15 BuildRequires: sqlite-devel, openssl-devel
16 Requires:       moonshot-gss-eap
17
18 %description
19 The trust router provides a mechanism for discovering the topology of
20 trust graphs in a topology and establishing temporary identities
21 between them.
22
23
24 %package        devel
25 Summary:        Development files for %{name}
26 Group:          Development/Libraries
27 Requires:       %{name}-libs = %{version}-%{release}
28
29 %description    devel
30 The %{name}-devel package contains libraries and header files for
31 developing applications that use %{name}-libs.
32
33 %package libs
34 Summary: Libraries needed by %{Name}
35
36 %description libs
37 This package includes libraries needed by the %{Name} package or
38 packages that wish trust_router functionality.
39
40
41
42
43 %prep
44 %setup -q
45
46
47 %build
48 %configure --disable-static
49 make %{?_smp_mflags}
50
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 make install DESTDIR=$RPM_BUILD_ROOT
55 find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
56
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61
62 %post libs -p /sbin/ldconfig
63
64 %postun libs -p /sbin/ldconfig
65
66
67 %files
68 %defattr(-,root,root,-)
69 %doc README
70 %{_bindir}/*
71 %{_datadir}/trust_router/schema.sql
72 /lib/systemd/system/tids.service
73
74 %files libs
75 %defattr(-,root,root,-)
76 %{_libdir}/*.so.*
77
78 %files devel
79 %defattr(-,root,root,-)
80 %{_includedir}/*
81 %{_libdir}/*.so
82
83
84