Include firefox extension packaging for centos
[gssweb.git] / gssweb.spec
1 %include %{_rpmconfigdir}/macros.mozilla
2 Name:           gssweb
3 Version:        0.1
4 Release:        1%{?dist}
5 Summary:        GSS-API for Javascript and the Web
6
7 Group:          Security Tools
8 License:        BSD
9 URL:            http://www.project-moonshot.org/
10 Source0:        gssweb-%{version}.tar.gz
11 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
12
13 BuildRequires:   openssl-devel, cppunit-devel, jansson-devel, krb5-devel, glib-devel
14 BuildRequires:  mozilla-build
15 Requires:       moonshot-ui
16
17
18
19 %description
20 This includes the json GSSAPI executables and libraries.
21
22 %package -n firefox-gssweb
23 Summary: Firefox Support for GssWeb
24 Arch: noarch
25
26
27 %prep
28 %setup -q -n gssweb
29
30
31 %build
32 %cmake
33 make %{?_smp_mflags}
34
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 make install DESTDIR=$RPM_BUILD_ROOT
39 %xpi_unpack -f browsers/firefox/gssweb.xpi
40 %xpi_symlink -a %{firefox_app_id}
41
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46
47 %files
48 %defattr(-,root,root,-)
49 %{_libdir}/libjsongssapi.so
50  %{_libdir}/libjsongssapi.so.*
51 %{_bindir}/json_gssapi
52 %files -n firefox-gssweb
53 %defattr(-,root,root,-)
54 %{_firefox_extdir}/
55 %{_mozilla_common_extdir}/%{name}/
56
57
58
59 %changelog
60